Bug 1729390 - Build failed with GenericBuildFailed reason when Configuring wrong Post Commit Build Hooks
Summary: Build failed with GenericBuildFailed reason when Configuring wrong Post Comm...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.3.0
Assignee: Adam Kaplan
QA Contact: wewang
URL:
Whiteboard: good-first-issue
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-12 07:42 UTC by wewang
Modified: 2020-01-22 15:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-22 15:14:37 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description wewang 2019-07-12 07:42:35 UTC
Description of problem:
Build failed with StatusReason GenericBuildFailed when Configuring wrong Post Commit Build Hooks

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-11-023129

How reproducible:
always

Steps to Reproduce:
1.Create app with wrong Post Commit Build Hooks

    "postCommit": {
       "script": "bundle exec invalid test"
    },

2. Check the build
$ oc get builds
NAME                  TYPE     FROM          STATUS                        STARTED          DURATION
ruby-sample-build-1   Source   Git@787f1be   Failed (GenericBuildFailed)   12 minutes ago   1m50s

3.

Actual results:
Build Failed with GenericBuildFailed reason

Expected results:
Build Failed with PostCommitHookFailed reason

Additional info:

Comment 1 wewang 2019-07-12 07:49:40 UTC
Seems in 4.x, just defined StatusReasonPostCommitHookFailed StatusReason = "PostCommitHookFailed" const, but it's not used.

Fyi, when build update that sets phase status failed should contain log snippet data, but cannot find any logSnippet data from logs of pod in  openshift-controller-manager namespace.

Comment 5 Adam Kaplan 2020-01-22 15:14:37 UTC
Closing this bug due to current engineering priorities, severity, availability of suitable workarounds and lack of customer cases. If this should be addressed, please reopen and provide additional details.


Note You need to log in before you can comment on or make changes to this bug.