Bug 1729423 - Remove /etc/httpd/conf.d/autoindex.conf to prevent override alias.conf in /etc/httpd/conf.modules.d/
Summary: Remove /etc/httpd/conf.d/autoindex.conf to prevent override alias.conf in /et...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-horizon
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z12
: 13.0 (Queens)
Assignee: Cédric Jeanneret
QA Contact: Radomir Dopieralski
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-12 08:49 UTC by Keigo Noha
Modified: 2020-06-24 11:33 UTC (History)
15 users (show)

Fixed In Version: puppet-horizon-12.4.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-24 11:33:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 710401 0 None MERGED Reflect openstacklib options for apache::vhost resources 2021-02-12 10:36:23 UTC
OpenStack gerrit 711900 0 None MERGED Reflect openstacklib options for apache::vhost resources 2021-02-12 10:36:23 UTC
Red Hat Knowledge Base (Solution) 4481841 0 None None None 2019-10-23 05:59:09 UTC
Red Hat Product Errata RHBA-2020:2718 0 None None None 2020-06-24 11:33:54 UTC

Description Keigo Noha 2019-07-12 08:49:47 UTC
Description of problem:
Remove /etc/httpd/conf.d/autoindex.conf to prevent override alias.conf in /etc/httpd/conf.modules.d/

In RHBZ#1648192, we tried to disable directory listing in icons/ directory.
However, autoindex.conf provided by httpd package overwrite the configuration of alias.conf in /etc/httpd/conf.modules.d.

Version-Release number of selected component (if applicable):
Current

How reproducible:
Always

Steps to Reproduce:
1. Deploy overcloud.
2. Login dashboard.
3. Access to http(s)://<dashboard URL>/icons/

Actual results:
The contents of icons directory are listed.

Expected results:
The contents of icons directory are not listed.

Additional info:
In puppet-apache, the module directory is automatically set based on httpd version.

https://github.com/puppetlabs/puppetlabs-apache/blob/74fa040be21689e32f156f73ed1a71f08a94eb49/spec/acceptance/version.rb#L20-L25

Comment 1 Keigo Noha 2019-07-12 08:51:39 UTC
If we can change the spec file of httpd, we just remove following lines from httpd.spec.

~~~
    573 # Split-out extra config shipped as default in conf.d:
    574 for f in autoindex; do
    575   mv docs/conf/extra/httpd-${f}.conf \
    576         $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/${f}.conf
    577 done
~~~

Comment 5 Keigo Noha 2019-09-02 00:23:14 UTC
Hi Team,

Do you have any updates on this?

Best Regards,
Keigo Noha

Comment 18 Cédric Jeanneret 2020-03-09 10:54:01 UTC
Queens patch needed some conflict resolution.  But it's ready: https://review.opendev.org/711900

Comment 30 errata-xmlrpc 2020-06-24 11:33:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2718


Note You need to log in before you can comment on or make changes to this bug.