Bug 1729437 - Usage Report table overlaps when view on smaller screen size
Summary: Usage Report table overlaps when view on smaller screen size
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.2.0
Assignee: David Taylor
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-12 09:25 UTC by Yadan Pei
Modified: 2019-10-16 06:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:29:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
UsageReportTableSmaller (65.88 KB, image/png)
2019-07-12 09:25 UTC, Yadan Pei
no flags Details
UsageReportTableNow (52.13 KB, image/png)
2019-08-27 08:23 UTC, Yadan Pei
no flags Details
LatestUsageReportTableSmaller (32.07 KB, image/png)
2019-09-10 02:26 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2605 None None None 2019-09-05 16:04:44 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:29:58 UTC

Description Yadan Pei 2019-07-12 09:25:51 UTC
Created attachment 1589818 [details]
UsageReportTableSmaller

Description of problem:
Usage Report table on Reports Details page are overlapped when viewing on smaller screen

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-11-114243

How reproducible:
Always

Steps to Reproduce:
1. Visit Chargeback -> Reports -> click on report to see its details
2.
3.

Actual results:
1. Usage Report table are in wrong format, see attachment

Expected results:
1. Usage Report table should be shown in correct format

Additional info:

Comment 1 David Taylor 2019-07-12 20:15:06 UTC
This might be resolved when we switch to the PF4 Table component.  I believe Patrick Riley was looking into do that work.

Comment 2 David Taylor 2019-08-23 13:53:37 UTC
Merged PR: https://github.com/openshift/console/pull/2155

Comment 3 Yadan Pei 2019-08-27 08:23:03 UTC
$ oc adm release info registry.svc.ci.openshift.org/ocp/release:4.2.0-0.nightly-2019-08-25-233755 --commits | grep console
  console                                       https://github.com/openshift/console                                       a5145e4dfe22c2d9e54e5afe3c731
$ git log a5145e4dfe22c2d9e54e5afe3c7314877531bb06 | grep '#2155'
    Merge pull request #2155 from dtaylor113/chargeback-pftable


The ordering arrow is not shown clearly, long namespaces are splited into many lines, see attachment

Comment 4 Yadan Pei 2019-08-27 08:23:37 UTC
Created attachment 1608410 [details]
UsageReportTableNow

Comment 5 Yadan Pei 2019-09-10 02:25:27 UTC
Now Usage Report table on smaller view is acceptable

Verified on 4.2.0-0.nightly-2019-09-08-180038

Comment 6 Yadan Pei 2019-09-10 02:26:51 UTC
Created attachment 1613409 [details]
LatestUsageReportTableSmaller

Comment 7 errata-xmlrpc 2019-10-16 06:29:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.