Bug 1729449 - Retrieval of fibre channel LUNs failed during hosted engine deploy with FC storage.
Summary: Retrieval of fibre channel LUNs failed during hosted engine deploy with FC st...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Hosted Engine
Version: 0.13.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.3.5
: 0.13.5
Assignee: Ido Rosenzwig
QA Contact: Wei Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-12 10:29 UTC by Wei Wang
Modified: 2019-07-30 14:08 UTC (History)
10 users (show)

Fixed In Version: cockpit-ovirt-0.13.5
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-30 14:08:07 UTC
oVirt Team: Node
sbonazzo: ovirt-4.3?
mavital: blocker?
sbonazzo: planning_ack?
sbonazzo: devel_ack+
weiwang: testing_ack+


Attachments (Terms of Use)
Log files (727.71 KB, application/gzip)
2019-07-12 10:29 UTC, Wei Wang
no flags Details
picture (59.02 KB, image/png)
2019-07-12 10:30 UTC, Wei Wang
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 101841 master MERGED Use named pipe on ISCSI and FC tasks 2019-07-22 09:50:33 UTC
oVirt gerrit 102014 ovirt-4.3 MERGED Use named pipe on ISCSI and FC tasks 2019-07-22 10:02:11 UTC

Description Wei Wang 2019-07-12 10:29:55 UTC
Created attachment 1589831 [details]
Log files

Description of problem:
Deploy hosted engine with FC storage, in the storage setting page, when user choose "Fibre Channel" storage type to retrieve, the error message "Retrieval of fibre channel LUNs failed" displays.

Version-Release number of selected component (if applicable):
RHVH-4.3-20190711.1-RHVH-x86_64-dvd1.iso
cockpit-machines-ovirt-195-1.el7.noarch
cockpit-bridge-195-1.el7.x86_64
cockpit-ws-195-1.el7.x86_64
cockpit-dashboard-195-1.el7.x86_64
cockpit-system-195-1.el7.noarch
cockpit-195-1.el7.x86_64
cockpit-ovirt-dashboard-0.13.4-1.el7ev.noarch
cockpit-storaged-195-1.el7.noarch
ovirt-hosted-engine-ha-2.3.3-1.el7ev.noarch
ovirt-hosted-engine-setup-2.3.11-1.el7ev.noarch
NetworkManager-1.18.0-5.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Clean install RHVH-4.3-20190711.1-RHVH-x86_64-dvd1.iso
2. Login to  "http://localhost:9090"
3. Deploy hosted engine with FC storage

Actual results:
"Retrieval of fibre channel LUNs failed" error message displays.

Expected results:
The retrieval of fibre channel luns successfully, the luns should be listed.

Additional info:

Comment 1 Wei Wang 2019-07-12 10:30:25 UTC
Created attachment 1589832 [details]
picture

Comment 2 Wei Wang 2019-07-25 06:24:08 UTC
Test Version
RHVH-4.3-20190723.0-RHVH-x86_64-dvd1.iso
cockpit-machines-ovirt-195-1.el7.noarch
cockpit-bridge-195-1.el7.x86_64
cockpit-ws-195-1.el7.x86_64
cockpit-dashboard-195-1.el7.x86_64
cockpit-system-195-1.el7.noarch
cockpit-195-1.el7.x86_64
cockpit-ovirt-dashboard-0.13.5-1.el7ev.noarch
cockpit-storaged-195-1.el7.noarch
ovirt-hosted-engine-ha-2.3.3-1.el7ev.noarch
ovirt-hosted-engine-setup-2.3.11-1.el7ev.noarch
rhvm-appliance-4.3-20190722.0.el7.rpm

Test steps:
According to comment 0

Result:
Hosted engine deploy successful with FC storage

Bug is fixed, move bug status to "VERIFIED"

Comment 3 Sandro Bonazzola 2019-07-30 14:08:07 UTC
This bugzilla is included in oVirt 4.3.5 release, published on July 30th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.5 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.