Bug 1729451 - SSL Everywhere: overcloud node delete caused a different node to delete in IDM [NEEDINFO]
Summary: SSL Everywhere: overcloud node delete caused a different node to delete in IDM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-novajoin
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: zstream
: 13.0 (Queens)
Assignee: Harry Rybacki
QA Contact: Jeremy Agee
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-12 10:35 UTC by Sadique Puthen
Modified: 2019-12-04 14:11 UTC (History)
26 users (show)

Fixed In Version: python-novajoin-1.2.0-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-07 14:04:36 UTC
Target Upstream Version:
amcleod: needinfo? (hrybacki)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 676731 'None' MERGED Fix backoff mechanism 2020-02-18 18:02:47 UTC
OpenStack gerrit 677037 'None' MERGED Refactor method names 2020-02-18 18:02:47 UTC
OpenStack gerrit 677038 'None' MERGED Add debug messages 2020-02-18 18:02:47 UTC
OpenStack gerrit 677498 'None' MERGED Handle add_host and delete_host cases more robustly 2020-02-18 18:02:47 UTC
Red Hat Product Errata RHBA-2019:3791 None None None 2019-11-07 14:04:51 UTC

Description Sadique Puthen 2019-07-12 10:35:04 UTC
Description of problem:

I am able to reproduce this.

$ openstack server list
+--------------------------------------+--------------+--------+----------------------+----------------+---------+
| ID                                   | Name         | Status | Networks             | Image          | Flavor  |
+--------------------------------------+--------------+--------+----------------------+----------------+---------+
| 20cc307e-3750-4734-bb04-f282a5eebc98 | controller-1 | ACTIVE | ctlplane=172.16.0.51 | overcloud-full | control |
| 2ee08272-1ac2-4bb7-94d7-813b9d133edc | ceph-3       | ACTIVE | ctlplane=172.16.0.73 | overcloud-full | ceph    |
| e9f49c4a-f7ab-4432-b86f-7cacc0831407 | compute-2    | ACTIVE | ctlplane=172.16.0.62 | overcloud-full | compute |
| a1a94cb0-a505-4162-b8eb-330f8473749d | controller-2 | ACTIVE | ctlplane=172.16.0.52 | overcloud-full | control |
| 105635ab-8aad-48da-a564-32d1afc5ec3e | ceph-2       | ACTIVE | ctlplane=172.16.0.72 | overcloud-full | ceph    |
| e916f4e7-c2e6-4ad3-8b0b-7ab3fbada04b | controller-3 | ACTIVE | ctlplane=172.16.0.53 | overcloud-full | control |
| 7c04eed0-11b9-4bad-80c1-7f0b2e68fa44 | ceph-1       | ACTIVE | ctlplane=172.16.0.71 | overcloud-full | ceph    |
| 0790e307-ab64-436a-9d1c-d8f7fa84532a | compute-1    | ACTIVE | ctlplane=172.16.0.61 | overcloud-full | compute |
+--------------------------------------+--------------+--------+----------------------+----------------+---------+

Removed compute-2 successfully.

command: overcloud node delete -> tripleoclient.v1.overcloud_node.DeleteNode (auth=True)
Using auth plugin: password
Deleting the following nodes from stack overcloud:
- e9f49c4a-f7ab-4432-b86f-7cacc0831407
Started Mistral Workflow tripleo.scale.v1.delete_node. Execution ID: 8c0add5c-7ab9-41f5-bbc3-95fb8a4471fd
Waiting for messages on queue 'tripleo' with no timeout.



END return value: None

$ openstack stack list
+--------------------------------------+------------+----------------------------------+-----------------+----------------------+----------------------+
| ID                                   | Stack Name | Project                          | Stack Status    | Creation Time        | Updated Time         |
+--------------------------------------+------------+----------------------------------+-----------------+----------------------+----------------------+
| 05f5fbba-5930-4095-9115-792fd4b0ae13 | overcloud  | 9c57467190614b43b9609f5940f4c02b | UPDATE_COMPLETE | 2019-07-12T06:35:35Z | 2019-07-12T09:26:54Z |
+--------------------------------------+------------+----------------------------------+-----------------+----------------------+----------------------+
(undercloud) [stack@undercloud ~]$ openstack server list
+--------------------------------------+--------------+--------+----------------------+----------------+---------+
| ID                                   | Name         | Status | Networks             | Image          | Flavor  |
+--------------------------------------+--------------+--------+----------------------+----------------+---------+
| 20cc307e-3750-4734-bb04-f282a5eebc98 | controller-1 | ACTIVE | ctlplane=172.16.0.51 | overcloud-full | control |
| 2ee08272-1ac2-4bb7-94d7-813b9d133edc | ceph-3       | ACTIVE | ctlplane=172.16.0.73 | overcloud-full | ceph    |
| a1a94cb0-a505-4162-b8eb-330f8473749d | controller-2 | ACTIVE | ctlplane=172.16.0.52 | overcloud-full | control |
| 105635ab-8aad-48da-a564-32d1afc5ec3e | ceph-2       | ACTIVE | ctlplane=172.16.0.72 | overcloud-full | ceph    |
| e916f4e7-c2e6-4ad3-8b0b-7ab3fbada04b | controller-3 | ACTIVE | ctlplane=172.16.0.53 | overcloud-full | control |
| 7c04eed0-11b9-4bad-80c1-7f0b2e68fa44 | ceph-1       | ACTIVE | ctlplane=172.16.0.71 | overcloud-full | ceph    |
| 0790e307-ab64-436a-9d1c-d8f7fa84532a | compute-1    | ACTIVE | ctlplane=172.16.0.61 | overcloud-full | compute |
+--------------------------------------+--------------+--------+----------------------+----------------+---------+

compute-2 is gone. See the difference in IDM.

# cat difference.txt
--- pre-delete.txt	2019-07-12 05:20:38.270030757 -0400
+++ post-delete.txt	2019-07-12 06:22:08.845030757 -0400
@@ -1,12 +1,6 @@
 ----------------
-43 hosts matched
+31 hosts matched
 ----------------
-  Host name: ceph-1.redhat.local
-  Description: IPA host for OpenStack
-  Principal name: host/ceph-1.redhat.local@REDHAT.LOCAL
-  Principal alias: host/ceph-1.redhat.local@REDHAT.LOCAL
-  SSH public key fingerprint: SHA256:ewD2/vvX/ombUi/upE9Oi9cqLiDeHVzcOcer1bq77B4 (ssh-rsa), SHA256:Wq3JrZNOrbCrO7m0+yJShJWC3JHGBgXKa9b4bNpLfI4 (ecdsa-sha2-nistp256), SHA256:BPXGBF3S3VpBYcfHPFpGJV/xFarZQnSoBeeSKrhii3o (ssh-ed25519)
-
   Host name: ceph-2.redhat.local
   Description: IPA host for OpenStack
   Principal name: host/ceph-2.redhat.local@REDHAT.LOCAL
@@ -29,54 +23,6 @@
   Principal alias: host/compute-1.redhat.local@REDHAT.LOCAL
   SSH public key fingerprint: SHA256:KQf7hN3LLthHzJVfO/McWEH31z8em9Ys3jTBgtnEY44 (ssh-rsa), SHA256:VdNdpwdEg11yyoweDZXZCfeashbZu7Gqs4iw9bvZyEE (ecdsa-sha2-nistp256), SHA256:ZPBZdABtsRuYEyj1VNSY6PoLqFAKq/DOfNZ78w+B4sM (ssh-ed25519)
 
-  Host name: compute-2.internalapi.redhat.local
-  Principal name: host/compute-2.internalapi.redhat.local@REDHAT.LOCAL
-  Principal alias: host/compute-2.internalapi.redhat.local@REDHAT.LOCAL
-
-  Host name: compute-2.redhat.local
-  Description: IPA host for OpenStack
-  Principal name: host/compute-2.redhat.local@REDHAT.LOCAL
-  Principal alias: host/compute-2.redhat.local@REDHAT.LOCAL
-  SSH public key fingerprint: SHA256:pxTIuoUTMA7S37e+aIE/6MVUvkhdUblHRtB+1/jMHtw (ssh-rsa), SHA256:9DmjvKXRBaMptFOQ964ASaMthqm2xitqVH6X/u92riM (ecdsa-sha2-nistp256), SHA256:f+zpuNDXgYpXzRGls5NicadmOem2vsVk3Iz1HfvKPEA (ssh-ed25519)
-
-  Host name: controller-1.ctlplane.redhat.local
-  Principal name: host/controller-1.ctlplane.redhat.local@REDHAT.LOCAL
-  Principal alias: host/controller-1.ctlplane.redhat.local@REDHAT.LOCAL
-
-  Host name: controller-1.external.redhat.local
-  Principal name: host/controller-1.external.redhat.local@REDHAT.LOCAL
-  Principal alias: host/controller-1.external.redhat.local@REDHAT.LOCAL
-
-  Host name: controller-1.internalapi.redhat.local
-  Principal name: host/controller-1.internalapi.redhat.local@REDHAT.LOCAL
-  Principal alias: host/controller-1.internalapi.redhat.local@REDHAT.LOCAL
-
-  Host name: controller-1.management.redhat.local
-  Principal name: host/controller-1.management.redhat.local@REDHAT.LOCAL
-  Principal alias: host/controller-1.management.redhat.local@REDHAT.LOCAL
-
-  Host name: controller-1.ocprovisioning.redhat.local
-  Principal name: host/controller-1.ocprovisioning.redhat.local@REDHAT.LOCAL
-  Principal alias: host/controller-1.ocprovisioning.redhat.local@REDHAT.LOCAL
-
-  Host name: controller-1.redhat.local
-  Description: IPA host for OpenStack
-  Principal name: host/controller-1.redhat.local@REDHAT.LOCAL
-  Principal alias: host/controller-1.redhat.local@REDHAT.LOCAL
-  SSH public key fingerprint: SHA256:lPXrfI/QFWkTHbTLCb8H9m9ordj1r6QDCEMI1domNxk (ssh-rsa), SHA256:T0Or8sil1p7E6Er1uSAHsoGcUbMCwIEdKkf+FOT/tw8 (ecdsa-sha2-nistp256), SHA256:jg2KPcLSEsRSD5hCpelBSlgXuT6r6taLHWhlVApx0As (ssh-ed25519)
-
-  Host name: controller-1.storage.redhat.local
-  Principal name: host/controller-1.storage.redhat.local@REDHAT.LOCAL
-  Principal alias: host/controller-1.storage.redhat.local@REDHAT.LOCAL
-
-  Host name: controller-1.storagemgmt.redhat.local
-  Principal name: host/controller-1.storagemgmt.redhat.local@REDHAT.LOCAL
-  Principal alias: host/controller-1.storagemgmt.redhat.local@REDHAT.LOCAL
-
-  Host name: controller-1.storagenfs.redhat.local
-  Principal name: host/controller-1.storagenfs.redhat.local@REDHAT.LOCAL
-  Principal alias: host/controller-1.storagenfs.redhat.local@REDHAT.LOCAL
-
   Host name: controller-2.ctlplane.redhat.local
   Principal name: host/controller-2.ctlplane.redhat.local@REDHAT.LOCAL
   Principal alias: host/controller-2.ctlplane.redhat.local@REDHAT.LOCAL
@@ -192,5 +138,5 @@
   Principal alias: host/undercloud.redhat.local@REDHAT.LOCAL
   SSH public key fingerprint: SHA256:jhW+5B3Wbs8Wes8rHGswx+KsZGlgdzxhC5So6J0gNfE (ssh-rsa), SHA256:06Cf884u+dFa69I5S4JiQnT9ceth9Ieg2F82f91ZgGo (ecdsa-sha2-nistp256), SHA256:KYwrcg+r9LmKTO9HeFvDmAPgSgFFSVpMsyd+XccQi7Y (ssh-ed25519)
 -----------------------------
-Number of entries returned 43
+Number of entries returned 31
 -----------------------------

The entire controller-1 and ceph-1 base entry is removed from IDM
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 69 Harry Rybacki 2019-09-13 18:33:37 UTC
Upstream patches have merged. Downstream build created. Updating FIV and moving RHBZ to MODIFIED.

Comment 88 Alex McLeod 2019-10-31 11:29:04 UTC
If this bug requires doc text for errata release, please set the 'Doc Type' and provide draft text according to the template in the 'Doc Text' field. The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to -.

Comment 90 errata-xmlrpc 2019-11-07 14:04:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3791

Comment 91 Harry Rybacki 2019-12-04 14:11:52 UTC
*** Bug 1751413 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.