Bug 1729453 - system-config-printer does not ship byte-compiled Python files
Summary: system-config-printer does not ship byte-compiled Python files
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-12 10:41 UTC by Lumír Balhar
Modified: 2019-07-15 11:55 UTC (History)
2 users (show)

Fixed In Version: system-config-printer-1.5.11-18.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-15 11:55:54 UTC


Attachments (Terms of Use)

Description Lumír Balhar 2019-07-12 10:41:30 UTC
system-config-printer-* packages should contain byte-compiled Python files. There is a try to byte-compile Python files in the specfile but the definition in %files sections don't seem to include any __pycache__ folder with byte-compiled Python files.

It seems that this is caused by a switch from Python 2 to Python 3 because Python 2 produces .pyc and .pyo files in the same folder as a source file is and %files sections contain an asterisk after every ".py" suffix.

Let me know if I can help you with anything.

Comment 1 Zdenek Dohnal 2019-07-15 11:55:54 UTC
Hi Lumir,

thank you for reporting the issue and your help! The issue is fixed in rawhide as build system-config-printer-1.5.11-18.fc31.


Note You need to log in before you can comment on or make changes to this bug.