Bug 1729454 - Inconsistent locale configuration
Summary: Inconsistent locale configuration
Keywords:
Status: CLOSED DUPLICATE of bug 1727489
Alias: None
Product: Fedora Container Images
Classification: Fedora
Component: base
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Clement Verna
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-12 10:44 UTC by Jan Pazdziora
Modified: 2019-07-20 05:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-12 17:15:04 UTC


Attachments (Terms of Use)

Description Jan Pazdziora 2019-07-12 10:44:49 UTC
Description of problem:

The base image configures

  LANG="en_US.UTF-8"

but that locale is not installed.

Version-Release number of selected component (if applicable):

registry.fedoraproject.org/fedora   30                  47c865867d25        7 days ago          261 MB

How reproducible:

Deterministic.

Steps to Reproduce:
1. docker run --rm registry.fedoraproject.org/fedora:30 cat /etc/locale.conf
LANG="en_US.UTF-8"
2. docker run --rm registry.fedoraproject.org/fedora:30 locale -a

Actual results:

LANG="en_US.UTF-8"

C
C.utf8
POSIX

Expected results:

Either LANG="C.utf8", or en_US.utf8 installed.

Additional info:

This also results in warnings in situations like

$ docker run --rm -ti registry.fedoraproject.org/fedora:30 bash
[root@b2a38ce51596 /]# dnf install zsh
Failed to set locale, defaulting to C.UTF-8

Comment 1 Jan Pazdziora 2019-07-12 10:45:02 UTC
I had to file this against version rawhide because bugzilla does not offer version 30. Please add the option of selecting version 30.

Comment 2 Jan Pazdziora 2019-07-12 10:45:27 UTC
This is Fedora equivalent of UBI bug 1700675.

Comment 3 Clement Verna 2019-07-12 17:15:04 UTC
I think this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1727489, I have open PRs to fix that https://pagure.io/fedora-kickstarts/pull-request/540 and https://pagure.io/fedora-kickstarts/pull-request/541

*** This bug has been marked as a duplicate of bug 1727489 ***

Comment 4 Jens Petersen 2019-07-20 05:22:33 UTC
(In reply to Jan Pazdziora from comment #2)
> This is Fedora equivalent of UBI bug 1700675.

UBI is also switching to LANG=C.utf8 which is the correct modern way.

Comment 5 Jens Petersen 2019-07-20 05:31:58 UTC
(In reply to Clement Verna from comment #3)
> I have open PRs to fix that
> https://pagure.io/fedora-kickstarts/pull-request/540 and
> https://pagure.io/fedora-kickstarts/pull-request/541

Okay, sorry, this fix does look good to me at least.
Do images with these changes exist already?


Note You need to log in before you can comment on or make changes to this bug.