Bug 1729462 - Fedora 30 won't boot with new Ryzen 3000 CPUs
Summary: Fedora 30 won't boot with new Ryzen 3000 CPUs
Keywords:
Status: CLOSED DUPLICATE of bug 1729268
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 30
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-12 11:03 UTC by sunsi.lucas
Modified: 2019-07-12 11:09 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-12 11:09:51 UTC


Attachments (Terms of Use)

Description sunsi.lucas 2019-07-12 11:03:17 UTC
Description of problem:


Version-Release number of selected component (if applicable): The one that comes with the current ISO. I think it's 242 but someone can correct me.


How reproducible:
This bug is affecting anyone that tries to boot the system with the current Ryzen 3000 Zen 2 CPU units.


Steps to Reproduce:
1. Boot the system from an ISO
2. It fails almost immediately
3.

Actual results:
System crashes at boot.


Expected results:
Booting to Fedora so we can install it.

Additional info:
This is likely a hardware issue from the CPUs that systemd has already patched but not yet released. Some distros are backporting the fix into their ISOs so it is bootable.

Related links:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1835809
https://www.phoronix.com/scan.php?page=news_item&px=Ryzen-3K-RdRand-Systemd-Maybe
https://forum.level1techs.com/t/ryzen-3000-booting-linux-and-you/144702
https://linuxreviews.org/AMD_Ryzen_3000_series_CPUs_can%27t_do_Random_on_boot_causing_Boot_Failure_on_newer_Linux_distributions

Comment 1 Zbigniew Jędrzejewski-Szmek 2019-07-12 11:09:51 UTC

*** This bug has been marked as a duplicate of bug 1729268 ***


Note You need to log in before you can comment on or make changes to this bug.