Bug 1729475 - Installation cannot complete when starting live image from partition
Summary: Installation cannot complete when starting live image from partition
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-12 11:25 UTC by Tomas Dabašinskas
Modified: 2019-07-24 03:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-23 11:37:25 UTC


Attachments (Terms of Use)
installation kickstart (1.68 KB, text/plain)
2019-07-12 11:25 UTC, Tomas Dabašinskas
no flags Details
packaging.log (4.81 KB, text/plain)
2019-07-12 11:25 UTC, Tomas Dabašinskas
no flags Details
storage.log (219.75 KB, text/plain)
2019-07-12 11:25 UTC, Tomas Dabašinskas
no flags Details
lvm.log (314.66 KB, text/plain)
2019-07-12 11:26 UTC, Tomas Dabašinskas
no flags Details
hawkey.log (51 bytes, text/plain)
2019-07-12 11:27 UTC, Tomas Dabašinskas
no flags Details
dbus.log (2.56 KB, text/plain)
2019-07-12 11:27 UTC, Tomas Dabašinskas
no flags Details
anaconda.log (19.65 KB, text/plain)
2019-07-12 11:28 UTC, Tomas Dabašinskas
no flags Details
proram.log (100.36 KB, text/plain)
2019-07-12 11:28 UTC, Tomas Dabašinskas
no flags Details

Description Tomas Dabašinskas 2019-07-12 11:25:01 UTC
Created attachment 1589847 [details]
installation kickstart

Description of problem:
I'm getting an error when trying to install fedora from live image when it's booted from a partition in the installation target drive

Version-Release number of selected component (if applicable):
 anaconda 31.18

How reproducible:



Steps to Reproduce:
1. copy live image to spare partition on the machine, label it 'live'
2. Setup grub custom.cfg (can also set root using path instead of partition label):

menuentry 'Start {{live_fs_label}} Fedora' --class fedora --class gnu-linux --class gnu --class os {
	load_video                                                                      
	set gfx_payload=text                                                           
	insmod gzio 

	search --no-floppy --set=root -l '{{live_fs_label}}'

	linux ($root)/isolinux/vmlinuz0 root=live:LABEL={{live_fs_label}} ro rd.live.image console=ttyS0
	initrd ($root)/isolinux/initrd0.img
}

3. Reboot and start from the local live image
4. Run installation using storage defined in ks (see ks-storage-exist.cfg attached)

Actual results:
No disks detected.  Please shut down the computer, connect at least one disk,
and restart to complete installation.


Expected results:
Installation to complete successfully

Additional info:
fdisk partition info
/dev/vda1      2048   411647   409600  200M EFI System
/dev/vda2    411648  2508799  2097152    1G Linux filesystem
/dev/vda3   2508800 20940799 18432000  8.8G Linux LVM
/dev/vda4  20940800 31180799 10240000  4.9G Linux filesystem

Comment 1 Tomas Dabašinskas 2019-07-12 11:25:35 UTC
Created attachment 1589848 [details]
packaging.log

Comment 2 Tomas Dabašinskas 2019-07-12 11:25:57 UTC
Created attachment 1589850 [details]
storage.log

Comment 3 Tomas Dabašinskas 2019-07-12 11:26:49 UTC
Created attachment 1589851 [details]
lvm.log

Comment 4 Tomas Dabašinskas 2019-07-12 11:27:08 UTC
Created attachment 1589852 [details]
hawkey.log

Comment 5 Tomas Dabašinskas 2019-07-12 11:27:51 UTC
Created attachment 1589853 [details]
dbus.log

Comment 6 Tomas Dabašinskas 2019-07-12 11:28:16 UTC
Created attachment 1589854 [details]
anaconda.log

Comment 7 Tomas Dabašinskas 2019-07-12 11:28:33 UTC
Created attachment 1589855 [details]
proram.log

Comment 8 Vendula Poncova 2019-07-23 11:37:25 UTC
Unfortunately, the installer doesn't support your use case. The live image cannot be on a disk that you want to use for the partitioning.

Comment 9 Tomas Dabašinskas 2019-07-24 03:25:59 UTC
Hi, thanks for reviewing the bug, imho it's a regression since this was working on fedora 29...

Comment 10 Tomas Dabašinskas 2019-07-24 03:28:07 UTC
apologies, I got confused with BZ#1729363


Note You need to log in before you can comment on or make changes to this bug.