Bug 1729487 - JS ERROR: TypeError: this._workspacesViews[i] is undefined
Summary: JS ERROR: TypeError: this._workspacesViews[i] is undefined
Keywords:
Status: CLOSED DUPLICATE of bug 1719279
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: gnome-shell
Version: 8.1
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-12 11:59 UTC by Michal Odehnal
Modified: 2019-08-09 10:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-12 12:17:13 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Michal Odehnal 2019-07-12 11:59:12 UTC
Description of problem:
Upon pressing super key to get to overview I see error message in journal

Version-Release number of selected component (if applicable):
gnome-shell-3.32.2-4.el8.x86_64
gnome-shell-3.32.2-5.el8.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Have running session.
2. Have in Terminal $ journalctl -fa
3. Pres Super key

Actual results:
gnome-shell[3138]: JS ERROR: TypeError: this._workspacesViews[i] is undefined
                   _updateWorkspacesFullGeometry@resource:///org/gnome/shell/ui/workspacesView.js:747:13
                   setWorkspacesFullGeometry@resource:///org/gnome/shell/ui/workspacesView.js:737:9
                   setWorkspacesFullGeometry@resource:///org/gnome/shell/ui/viewSelector.js:293:9
                   _updateWorkspacesGeometry@resource:///org/gnome/shell/ui/overviewControls.js:456:9
                   vfunc_allocate@resource:///org/gnome/shell/ui/overviewControls.js:389:9
                   _updateWorkspacesViews@resource:///org/gnome/shell/ui/workspacesView.js:670:13
                   show@resource:///org/gnome/shell/ui/workspacesView.js:590:9
                   show@resource:///org/gnome/shell/ui/viewSelector.js:268:9
                   _animateVisible@resource:///org/gnome/shell/ui/overview.js:527:9
                   show@resource:///org/gnome/shell/ui/overview.js:513:9
                   toggle@resource:///org/gnome/shell/ui/overview.js:636:13
                   _initializeUI/<@resource:///org/gnome/shell/ui/main.js:190:13


Expected results:
No errors

Additional info:
This is standard gnome-shell session

Comment 1 Tomas Pelka 2019-07-12 12:17:13 UTC

*** This bug has been marked as a duplicate of bug 1719279 ***


Note You need to log in before you can comment on or make changes to this bug.