Bug 172956 - emergency shutdown silenty leads to panic
emergency shutdown silenty leads to panic
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: dlm (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Teigland
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-11 11:10 EST by David Teigland
Modified: 2010-01-05 15:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-05 15:26:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Teigland 2005-11-11 11:10:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:
If cman loses its connection to the cluster, it
forcibly shuts down the dlm using dlm_emergency_shutdown.
If the dlm is in use by gfs, as it often is, this
causes gfs to panic when it finds that its dlm locks
have suddenly gone away.

The problem is that it's never clear from the gfs panic
whether the root cause was an emergency shutdown or
something else.  In fact, there's often nothing on the
console or in the saved messages to clearly show
whether an emergency shutdown occured.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run gfs
2. kick node from cluster
3.
  

Actual Results:  gfs/lock_dlm assertion panic

Expected Results:  loud warning that node was kicked from cluster
followed by gfs/lock_dlm assertion panic


Additional info:
Comment 1 David Teigland 2005-11-15 11:35:10 EST
Added printk("WARNING: dlm_emergency_shutdown\n") to help diagnose panics.
Comment 2 David Teigland 2010-01-05 15:26:49 EST
This was added many years ago.

Note You need to log in before you can comment on or make changes to this bug.