Bug 1729592 - Failure to deploy overcloud in early testing
Summary: Failure to deploy overcloud in early testing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 15.0 (Stein)
Assignee: Emilien Macchi
QA Contact: Victor Voronkov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-12 18:32 UTC by Lon Hohberger
Modified: 2019-09-27 10:43 UTC (History)
4 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.6.1-0.20190713150434.2871ce0.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:23:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 670082 0 None None None 2019-07-12 18:37:45 UTC
OpenStack gerrit 670663 0 None None None 2019-07-14 21:11:33 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:24:11 UTC

Description Lon Hohberger 2019-07-12 18:32:50 UTC
Description of problem: Overcloud deployment fails

Version-Release number of selected component (if applicable): 10.6.1-0.20190711090428.245f17c.el8ost

How reproducible: 100%

Steps to Reproduce:
1. Attempt to deploy overcloud

Actual results: Failure to deploy:

2019-07-12 17:15:43.475 | fatal: [compute-0]: FAILED! => {"msg": "An unhandled exception occurred while running the lookup plugin 'dict'. Error was a <class 'ansible.errors.AnsibleError'>, original message: with_dict expects a dict"}

Expected results:

Successful deployment

Additional info:

A related review (include above) for a similar issue concerning undercloud:
  https://review.opendev.org/#/c/670082/

The merge commit including the above is 245f17c, which is the THT build we have above:

  https://github.com/openstack/tripleo-heat-templates/commit/245f17c3df67c6fff89676003c676439bd7f7e64

Comment 2 Lon Hohberger 2019-07-14 21:11:09 UTC
This should be resolved by: https://review.opendev.org/#/c/670663/

Comment 9 Victor Voronkov 2019-07-15 10:50:33 UTC
Verified on RHOS_TRUNK-15.0-RHEL-8-20190714.n.0
Overcloud deployed successfully

Comment 14 errata-xmlrpc 2019-09-21 11:23:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.