Bug 1729628 - rust-chrono-devel should depend on rust-time-devel
Summary: rust-chrono-devel should depend on rust-time-devel
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rust-chrono
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1675615
TreeView+ depends on / blocked
 
Reported: 2019-07-13 00:21 UTC by Gris Ge
Modified: 2019-07-13 06:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-13 06:37:22 UTC


Attachments (Terms of Use)

Description Gris Ge 2019-07-13 00:21:25 UTC
Description of problem:


+ /usr/bin/env CARGO_HOME=.cargo RUSTC_BOOTSTRAP=1 /usr/bin/cargo build -j2 -Z avoid-dev-deps --release
error: no matching package named `time` found
location searched: registry `https://github.com/rust-lang/crates.io-index`
perhaps you meant: toml, libc or nix
required by package `chrono v0.4.7`
    ... which is depended on by `peripetyd v0.1.0 (/root/rpmbuild/BUILD/peripety-0.1.2/src/peripetyd)`
error: Bad exit status from /var/tmp/rpm-tmp.cbaJZ1 (%build)


Version-Release number of selected component (if applicable):
rust-chrono-devel-0.4.7-1.fc31.noarch

How reproducible:
100%

Steps to Reproduce:
1. 
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Igor Gnatenko 2019-07-13 06:37:22 UTC
You need to depend on crate(chrono/default) in your spec file since your package uses default features.


Note You need to log in before you can comment on or make changes to this bug.