Bug 1729639 - gnome-software segmentation fault on 3.32.4
Summary: gnome-software segmentation fault on 3.32.4
Keywords:
Status: CLOSED DUPLICATE of bug 1697566
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 30
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-13 02:54 UTC by Pablo Estigarribia
Modified: 2019-07-15 07:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-15 07:09:46 UTC
Type: Bug


Attachments (Terms of Use)
gnome-software --verbose output (83.76 KB, text/plain)
2019-07-13 02:56 UTC, Pablo Estigarribia
no flags Details

Description Pablo Estigarribia 2019-07-13 02:54:32 UTC
Description of problem:

systemd-coredump[7864]: Process 7807 (gnome-software) of user 1000 dumped core.
                                               
                                               Stack trace of thread 7824:
                                               #0  0x00007fae0d96384c n/a (libcurl.so.4)
                                               #1  0x00007fae0d963b0b curl_multi_socket_action (libcurl.so.4)
                                               #2  0x00007fae0da6c37a n/a (libostree-1.so.1)
                                               #3  0x00007fae2029fedd g_main_context_dispatch (libglib-2.0.so.0)
                                               #4  0x00007fae202a0270 n/a (libglib-2.0.so.0)
                                               #5  0x00007fae202a0313 g_main_context_iteration (libglib-2.0.so.0)
                                               #6  0x00007fae0da698d6 n/a (libostree-1.so.1)
                                               #7  0x00007fae0da2a0a2 n/a (libostree-1.so.1)
                                               #8  0x00007fae0da356ae ostree_repo_remote_fetch_summary_with_options (libostree-1.so.1)
                                               #9  0x00007fae0da1233a ostree_repo_remote_fetch_summary (libostree-1.so.1)
                                               #10 0x00007fae0dbad722 n/a (libflatpak.so.0)
                                               #11 0x00007fae0dbadefc n/a (libflatpak.so.0)
                                               #12 0x00007fae0dbf2f9c flatpak_installation_list_remote_refs_sync_full (libflatpak.so.0)
                                               #13 0x00007fae0dbf3242 flatpak_installation_list_installed_refs_for_update (libflatpak.so.0)
                                               #14 0x00007fae0dca4317 gs_flatpak_add_updates (libgs_plugin_flatpak.so)
                                               #15 0x00007fae0dca7f35 gs_plugin_add_updates (libgs_plugin_flatpak.so)
                                               #16 0x0000559fd5919dfb n/a (gnome-software)
                                               #17 0x0000559fd591a372 n/a (gnome-software)
                                               #18 0x0000559fd591b433 n/a (gnome-software)
                                               #19 0x00007fae20126907 n/a (libgio-2.0.so.0)
                                               #20 0x00007fae202c9f14 n/a (libglib-2.0.so.0)
                                               #21 0x00007fae202c94e2 n/a (libglib-2.0.so.0)
                                               #22 0x00007fae1f3905a2 start_thread (libpthread.so.0)
                                               #23 0x00007fae1f2bb303 __clone (libc.so.6)
                                               
                                               Stack trace of thread 7807:
                                               #0  0x00007fae1fc90410 n/a (libgtk-3.so.0)
                                               #1  0x00007fae1fa37634 n/a (libgtk-3.so.0)
                                               #2  0x00007fae1fa3a176 n/a (libgtk-3.so.0)
                                               #3  0x00007fae202a384a n/a (libglib-2.0.so.0)
                                               #4  0x00007fae202a4b97 g_markup_parse_context_parse (libglib-2.0.so.0)
                                               #5  0x00007fae1fa3ac5e n/a (libgtk-3.so.0)
                                               #6  0x00007fae1fa35a90 gtk_builder_extend_with_template (libgtk-3.so.0)
                                               #7  0x00007fae1fca2386 gtk_widget_init_template (libgtk-3.so.0)
                                               #8  0x0000559fd58c6625 n/a (gnome-software)
                                               #9  0x00007fae203af101 g_type_create_instance (libgobject-2.0.so.0)
                                               #10 0x00007fae2039142d n/a (libgobject-2.0.so.0)
                                               #11 0x00007fae20392b15 g_object_new_with_properties (libgobject-2.0.so.0)
                                               #12 0x00007fae203936c1 g_object_new (libgobject-2.0.so.0)
                                               #13 0x0000559fd58c7f11 gs_app_row_new (gnome-software)
                                               #14 0x0000559fd58dec5f n/a (gnome-software)
                                               #15 0x0000559fd58df358 n/a (gnome-software)
                                               #16 0x00007fae20125c1a n/a (libgio-2.0.so.0)
                                               #17 0x00007fae20125c5d n/a (libgio-2.0.so.0)
                                               #18 0x00007fae2029c7db n/a (libglib-2.0.so.0)
                                               #19 0x00007fae2029fedd g_main_context_dispatch (libglib-2.0.so.0)
                                               #20 0x00007fae202a0270 n/a (libglib-2.0.so.0)
                                               #21 0x00007fae202a0313 g_main_context_iteration (libglib-2.0.so.0)
                                               #22 0x00007fae20153495 g_application_run (libgio-2.0.so.0)
                                               #23 0x0000559fd58ba49d main (gnome-software)
                                               #24 0x00007fae1f1e3f33 __libc_start_main (libc.so.6)
                                               #25 0x0000559fd58ba54e _start (gnome-software)
                                               
                                               Stack trace of thread 7809:
                                               #0  0x00007fae1f2b05c7 __poll (libc.so.6)
                                               #1  0x00007fae202a01de n/a (libglib-2.0.so.0)
                                               #2  0x00007fae202a05a3 g_main_loop_run (libglib-2.0.so.0)
                                               #3  0x00007fae2018ed6a n/a (libgio-2.0.so.0)
                                               #4  0x00007fae202c94e2 n/a (libglib-2.0.so.0)
                                               #5  0x00007fae1f3905a2 start_thread (libpthread.so.0)
                                               #6  0x00007fae1f2bb303 __clone (libc.so.6)
                                               
                                               Stack trace of thread 7839:
                                               #0  0x00007fae1f2b5fad syscall (libc.so.6)
                                               #1  0x00007fae202ebf56 g_cond_wait_until (libglib-2.0.so.0)
                                               #2  0x00007fae20271031 n/a (libglib-2.0.so.0)
                                               #3  0x00007fae20271656 g_async_queue_timeout_pop (libglib-2.0.so.0)
                                               #4  0x00007fae202c9fb9 n/a (libglib-2.0.so.0)
                                               #5  0x00007fae202c94e2 n/a (libglib-2.0.so.0)
                                               #6  0x00007fae1f3905a2 start_thread (libpthread.so.0)
                                               #7  0x00007fae1f2bb303 __clone (libc.so.6)
                                               
                                               Stack trace of thread 7808:
                                               #0  0x00007fae1f2b05c7 __poll (libc.so.6)
                                               #1  0x00007fae202a01de n/a (libglib-2.0.so.0)
                                               #2  0x00007fae202a0313 g_main_context_iteration (libglib-2.0.so.0)
                                               #3  0x00007fae202a0361 n/a (libglib-2.0.so.0)
                                               #4  0x00007fae202c94e2 n/a (libglib-2.0.so.0)
                                               #5  0x00007fae1f3905a2 start_thread (libpthread.so.0)
                                               #6  0x00007fae1f2bb303 __clone (libc.so.6)
                                               
                                               Stack trace of thread 7811:
                                               #0  0x00007fae1f2b05c7 __poll (libc.so.6)
                                               #1  0x00007fae202a01de n/a (libglib-2.0.so.0)
                                               #2  0x00007fae202a0313 g_main_context_iteration (libglib-2.0.so.0)
                                               #3  0x00007fae0ee02a9d n/a (libdconfsettings.so)
                                               #4  0x00007fae202c94e2 n/a (libglib-2.0.so.0)
                                               #5  0x00007fae1f3905a2 start_thread (libpthread.so.0)
                                               #6  0x00007fae1f2bb303 __clone (libc.so.6)
                                               
                                               Stack trace of thread 7838:
                                               #0  0x00007fae1f2b5fad syscall (libc.so.6)
                                               #1  0x00007fae202ebf56 g_cond_wait_until (libglib-2.0.so.0)
                                               #2  0x00007fae20271031 n/a (libglib-2.0.so.0)
                                               #3  0x00007fae202ca06a n/a (libglib-2.0.so.0)
                                               #4  0x00007fae202c94e2 n/a (libglib-2.0.so.0)
                                               #5  0x00007fae1f3905a2 start_thread (libpthread.so.0)
                                               #6  0x00007fae1f2bb303 __clone (libc.so.6)



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. open gnome-sfotware 3.32.4 on fedora 30
2. crash!
3.

Actual results:

core dump crash!

Expected results:

just works

Additional info:

Comment 1 Pablo Estigarribia 2019-07-13 02:56:10 UTC
Created attachment 1590121 [details]
gnome-software --verbose output

gnome-software --verbose > gnome-software.log
02:50:26:0055 Gs  not handling error failed for action get-updates-historical: failed to build result for 2fe2d0ff497f17739d8709f20079b03134f99be5
02:50:27:0571 Gs  State change on system/package/updates/desktop/firefox.desktop/* from updatable to installed is not OK

Comment 2 Kalev Lember 2019-07-15 07:09:46 UTC
This is a crash we are tracking in a libcurl ticket.

*** This bug has been marked as a duplicate of bug 1697566 ***


Note You need to log in before you can comment on or make changes to this bug.