Bug 1729671 - "yum-builddep libreoffice" fails to complete due to "Error: Invalid version flag: if"
Summary: "yum-builddep libreoffice" fails to complete due to "Error: Invalid version f...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-13 11:32 UTC by krichter@posteo.de
Modified: 2019-07-18 07:55 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-18 07:55:46 UTC


Attachments (Terms of Use)

Description krichter@posteo.de 2019-07-13 11:32:16 UTC
Description of problem:
`yum-builddep libreoffice` fails to complete due to `Error: Invalid version flag: if` on Docker image `fedora:30`

Version-Release number of selected component (if applicable):
30

How reproducible:


Steps to Reproduce:
1. docker run -it fedora:30
2. yum install -y yum-utils
3. yum-builddep libreoffice

Actual results:
The command finishes with "Error: Invalid version flag: if" and advises that `--skip-broken` can be used.

Expected results:
The command should terminated successfully without a warning even though `--skip-broken` probably allows to work around the issue.

Additional info:

Comment 1 David Tardon 2019-07-15 11:36:06 UTC
`dnf builddep libreoffice` works just fine.

Comment 2 Michal Domonkos 2019-07-18 07:55:46 UTC
Unfortunately, YUM-3 doesn't support boolean deps.  Moreover, YUM-3 is deprecated and completely removed from Fedora 31.  Please use "dnf builddep" from the dnf-plugins-core package instead.


Note You need to log in before you can comment on or make changes to this bug.