Bug 1729697 - hybrid-sleep on AMD Ryzen 5 1500X does not work
Summary: hybrid-sleep on AMD Ryzen 5 1500X does not work
Keywords:
Status: CLOSED DUPLICATE of bug 1661832
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-13 16:50 UTC by customercare
Modified: 2019-10-24 07:46 UTC (History)
23 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-20 18:41:07 UTC
customercare: needinfo-


Attachments (Terms of Use)

Description customercare 2019-07-13 16:50:43 UTC
Description of problem:

activating hybrid sleep via systemd or Cinnamon energy safe options
does not work as expected.

Case a)

executing "/usr/lib/systemd/systemd-sleep hybrid-sleep" as root


System shuts down the gfx card, but does not suspend nor hibernate the system.
A ssh session is kept active, but could not reactivate the systems gfx card.
rebooting fails, as the pc gets stuck, but does not power down at all nor reboots.

Case b)

Waiting for the energy management to hybrid-suspend the pc, ends in :

a wake gfx card, showing the last scene from the desktop
no reaction to keyboard inputs
no reaction to "reset" button on pc casing. 
-- unconfirmed : (could also be a level 8 problem ;) )
no reaction to "long press" on the power-button 

After power down/up, pc boots normally, no sign of hibernation resume. 


Version-Release number of selected component (if applicable):

5.1.16-200.fc29.x86_64
systemd-239-12.git8bca462.fc29.x86_64

Base Board Information
        Manufacturer: ASUSTeK COMPUTER INC.
        Product Name: PRIME A320M-K
        Version: Rev X.0x

Processor Information
        Socket Designation: AM4
        Type: Central Processor
        Family: Zen
        Manufacturer: Advanced Micro Devices, Inc.
        ID: 11 0F 80 00 FF FB 8B 17
        Signature: Family 23, Model 1, Stepping 1
        Flags:
                FPU (Floating-point unit on-chip)
                VME (Virtual mode extension)
                DE (Debugging extension)
                PSE (Page size extension)
                TSC (Time stamp counter)
                MSR (Model specific registers)
                PAE (Physical address extension)
                MCE (Machine check exception)
                CX8 (CMPXCHG8 instruction supported)
                APIC (On-chip APIC hardware supported)
                SEP (Fast system call)
                MTRR (Memory type range registers)
                PGE (Page global enable)
                MCA (Machine check architecture)
                CMOV (Conditional move instruction supported)
                PAT (Page attribute table)
                PSE-36 (36-bit page size extension)
                CLFSH (CLFLUSH instruction supported)
                MMX (MMX technology supported)
                FXSR (FXSAVE and FXSTOR instructions supported)
                SSE (Streaming SIMD extensions)
                SSE2 (Streaming SIMD extensions 2)
                HTT (Multi-threading)
        Version: AMD Ryzen 5 1500X Quad-Core Processor          
        Voltage: 1.2 V
        External Clock: 100 MHz
        Max Speed: 3900 MHz
        Current Speed: 3500 MHz
        Status: Populated, Enabled
        Upgrade: Socket AM4
        L1 Cache Handle: 0x0025
        L2 Cache Handle: 0x0026
        L3 Cache Handle: 0x0027
        Serial Number: Unknown
        Asset Tag: Unknown
        Part Number: Unknown
        Core Count: 4
        Core Enabled: 4
        Thread Count: 8
        Characteristics:
                64-bit capable
                Multi-Core
                Hardware Thread
                Execute Protection
                Enhanced Virtualization
                Power/Performance Control

Comment 1 Zbigniew Jędrzejewski-Szmek 2019-07-21 10:05:16 UTC
> System shuts down the gfx card, but does not suspend nor hibernate the system.

Systemd just tells the kernel to hibernate. If things go wrong at this stage, it's
a kernel driver issue.

Comment 2 Justin M. Forbes 2019-08-20 17:45:20 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 29 kernel bugs.

Fedora 29 has now been rebased to 5.2.9-100.fc29.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 30, and are still experiencing this issue, please change the version to Fedora 30.

If you experience different issues, please open a new bug report for those.

Comment 3 customercare 2019-08-20 17:54:15 UTC
Energy state problems with that cpu got resolved, by disabling CPU C6 state entirely. 

We will test Hybrid Sleep now and will report back.

Comment 4 Zbigniew Jędrzejewski-Szmek 2019-08-20 18:41:07 UTC
Seems to be the same as the other bug.

*** This bug has been marked as a duplicate of bug 1661832 ***

Comment 5 customercare 2019-10-22 10:24:52 UTC
Clearing needinfo request,

btw: disabling C6 cpu sleep stae FIXED it !


Note You need to log in before you can comment on or make changes to this bug.