Bug 1729773 - [abrt] backintime-common: flush(): snapshotlog.py:203:flush:RuntimeError: reentrant call inside <_io.BufferedWriter name='/root/.local/share/backintime/takesnapshot_3.log'>
Summary: [abrt] backintime-common: flush(): snapshotlog.py:203:flush:RuntimeError: ree...
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: backintime
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: hannes
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:e850803b76452d33aae83b643df...
: 1733803 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-14 13:11 UTC by Matt Fagnani
Modified: 2020-05-26 16:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-26 16:20:34 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.53 KB, text/plain)
2019-07-14 13:11 UTC, Matt Fagnani
no flags Details
File: cgroup (331 bytes, text/plain)
2019-07-14 13:11 UTC, Matt Fagnani
no flags Details
File: environ (249 bytes, text/plain)
2019-07-14 13:11 UTC, Matt Fagnani
no flags Details
File: mountinfo (3.79 KB, text/plain)
2019-07-14 13:11 UTC, Matt Fagnani
no flags Details
File: namespaces (129 bytes, text/plain)
2019-07-14 13:11 UTC, Matt Fagnani
no flags Details

Description Matt Fagnani 2019-07-14 13:11:02 UTC
Description of problem:
I logged into Plasma 5.15.5 on Wayland in an F30 KDE Plasma spin installation. I started Back in time (root) from the menu. I added a new profile to backup / . I selected to save the file permissions and extended attributes. I added /usr/src/debug and /usr/lib/debug to the exclude list. 

I started a snapshot to backup to an external USB hard drive. The snapshot stopped around 60% of the way, and Done was shown in the bottom of the screen. I had selected to check the snapshot log which showed the snapshot had stopped midway. No completed snapshot was in the list on the left of the window. I found this error in gnome-abrt later. The second time I tried this snapshot, it completed correctly without this error.

This problem with the same error and trace was reported by others at https://github.com/bit-team/backintime/issues/1003

Version-Release number of selected component:
backintime-common-1.2.0-3.fc30

Additional info:
reporter:       libreport-2.10.1
cmdline:        python3 -Es /usr/share/backintime/common/backintime.py --profile-id 3 backup
crash_function: flush
exception_type: RuntimeError
executable:     /usr/share/backintime/common/backintime.py
interpreter:    python3-3.7.4-1.fc30.x86_64
kernel:         5.1.17-300.fc30.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
snapshotlog.py:203:flush:RuntimeError: reentrant call inside <_io.BufferedWriter name='/root/.local/share/backintime/takesnapshot_3.log'>

Traceback (most recent call last):
  File "/usr/share/backintime/common/backintime.py", line 1165, in <module>
    startApp()
  File "/usr/share/backintime/common/backintime.py", line 517, in startApp
    args.func(args)
  File "/usr/share/backintime/common/backintime.py", line 739, in backup
    ret = takeSnapshot(cfg, force)
  File "/usr/share/backintime/common/backintime.py", line 94, in takeSnapshot
    ret = snapshots.Snapshots(cfg).backup(force)
  File "/usr/share/backintime/common/snapshots.py", line 692, in backup
    ret_val, ret_error = self.takeSnapshot(sid, now, include_folders)
  File "/usr/share/backintime/common/snapshots.py", line 1036, in takeSnapshot
    proc.run()
  File "/usr/share/backintime/common/tools.py", line 1981, in run
    self.callback(line, self.user_data)
  File "/usr/share/backintime/common/snapshots.py", line 809, in rsyncCallback
    self.snapshotLog.append('[C] ' + line[12:], 2)
  File "/usr/share/backintime/common/snapshotlog.py", line 195, in append
    self.logFile.write(msg + '\n')
  File "/usr/share/backintime/common/tools.py", line 1513, in handler
    self.callback()
  File "/usr/share/backintime/common/snapshotlog.py", line 203, in flush
    self.logFile.flush()
RuntimeError: reentrant call inside <_io.BufferedWriter name='/root/.local/share/backintime/takesnapshot_3.log'>

Local variables in innermost frame:
self: <snapshotlog.SnapshotLog object at 0x7faa6a4e2e10>

Comment 1 Matt Fagnani 2019-07-14 13:11:04 UTC
Created attachment 1590511 [details]
File: backtrace

Comment 2 Matt Fagnani 2019-07-14 13:11:05 UTC
Created attachment 1590512 [details]
File: cgroup

Comment 3 Matt Fagnani 2019-07-14 13:11:06 UTC
Created attachment 1590513 [details]
File: environ

Comment 4 Matt Fagnani 2019-07-14 13:11:07 UTC
Created attachment 1590514 [details]
File: mountinfo

Comment 5 Matt Fagnani 2019-07-14 13:11:08 UTC
Created attachment 1590515 [details]
File: namespaces

Comment 6 hannes 2019-07-29 04:38:54 UTC
*** Bug 1733803 has been marked as a duplicate of this bug. ***

Comment 7 Ben Cotton 2020-04-30 21:28:34 UTC
This message is a reminder that Fedora 30 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 30 on 2020-05-26.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '30'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 30 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 8 Ben Cotton 2020-05-26 16:20:34 UTC
Fedora 30 changed to end-of-life (EOL) status on 2020-05-26. Fedora 30 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.