Bug 1729799 - Row freezes when attempting to add a NIC or disk from VM detail panels
Summary: Row freezes when attempting to add a NIC or disk from VM detail panels
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Container Native Virtualization (CNV)
Classification: Red Hat
Component: User Experience
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 2.1.0
Assignee: Filip Krepinsky
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-14 20:07 UTC by Phillip Bailey
Modified: 2019-11-04 15:06 UTC (History)
4 users (show)

Fixed In Version: 4.2.0-0.nightly-2019-08-15-073735
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-04 15:06:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
Frozen row (90.57 KB, image/png)
2019-07-14 20:07 UTC, Phillip Bailey
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 1979 None None None 2019-07-16 11:19:13 UTC

Description Phillip Bailey 2019-07-14 20:07:34 UTC
Created attachment 1590569 [details]
Frozen row

Description of problem:

When attempting to add a disk or NIC, the row being added freezes in the disabled state once the check mark button is clicked. The disk/NIC is added and can be seen by refreshing the page or navigating away from the list view and back again.


Version-Release number of selected component (if applicable): 2.1


How reproducible: 100%


Steps to Reproduce:
1. Navigate to the details view of a VM by selecting "Workloads" -> "Virtual Machines" in the side navigation and clicking the name of a VM
2. Click on the "Disks" tab
3. Click the "Create Disk" button
4. Enter acceptable values into the "Name", "Size", and "Storage Class" fields
5. Click the check mark button

Actual results:
The row freezes in the disabled state.


Expected results:
The row is added to the list of read-only rows

Comment 1 Tomas Jelinek 2019-07-15 11:56:28 UTC
This has been found on the 2.1 version and is not present in to 2.0, targeting to 2.1 since it has to be fixed for sure.

Comment 2 Radim Hrazdil 2019-08-20 14:28:14 UTC
Verified
INSTALLER_VERSION=4.2.0-0.nightly-2019-08-15-073735
HCO-v2.1.0-13


Note You need to log in before you can comment on or make changes to this bug.