Bug 1729866 - OSP14 OVN- Rally NeutronNetworks.create_and_list_ports test failed
Summary: OSP14 OVN- Rally NeutronNetworks.create_and_list_ports test failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: ---
Assignee: Terry Wilson
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks: 1737432
TreeView+ depends on / blocked
 
Reported: 2019-07-15 07:44 UTC by Eran Kuris
Modified: 2020-03-05 11:54 UTC (History)
6 users (show)

Fixed In Version: python-networking-ovn-6.0.1-0.20191018200435.704a4cc.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1737432 (view as bug list)
Environment:
Last Closed: 2020-03-05 11:53:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1838969 0 None None None 2019-08-05 11:09:05 UTC
OpenStack gerrit 687568 0 None MERGED Avoid port group creation race 2021-02-20 12:55:16 UTC
Red Hat Product Errata RHBA-2020:0709 0 None None None 2020-03-05 11:54:19 UTC

Description Eran Kuris 2019-07-15 07:44:49 UTC
Description of problem:
The Rally test NeutronNetworks.create_and_list_ports failed:

controller-0/var/log/containers/neutron/server.log.1:2019-07-14 14:38:19.665 31 ERROR neutron.plugins.ml2.managers [req-785fdb51-0cbb-48d2-ad3a-42ead52405c9 4ae467e29c93404bbb765327298cd8f9 560c31a384794fc2b3a1ad8265da87a1 - default default] Mechanism driver 'ovn' failed in create_port_postcommit: RuntimeError: OVSDB Error: {"details":"Transaction causes multiple rows in \"Port_Group\" table to have identical values (neutron_pg_drop) for index on column \"name\". 
and then the rally request fails: 

controller-0/var/log/containers/neutron/server.log.1:2019-07-14 14:38:19.665 31 ERROR neutron.plugins.ml2.managers [req-785fdb51-0cbb-48d2-ad3a-42ead52405c9 4ae467e29c93404bbb765327298cd8f9 560c31a384794fc2b3a1ad8265da87a1 - default default] Mechanism driver 'ovn' failed in create_port_postcommit: RuntimeError: OVSDB Error: {"details":"Transaction causes 

multiple rows in \"Port_Group\" table to have identical values (neutron_pg_drop) for index on column \"name\". 
so it looks, like (from the first message) that two ports tried to have the same value in "name" column which is an index so that's not allowed 
so Rally managed to break the ovndb service with concurrency

Version-Release number of selected component (if applicable):
OSP14- core_puddle: 2019-06-26.1

How reproducible:
100%

Steps to Reproduce:
1. run the job https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/DFG/view/network/view/networking-ovn/job/DFG-network-networking-ovn-14_director-rhel-virthost-3cont_2comp-ipv4-geneve-dvr-rally/135/
2.
3.

Actual results:


Expected results:


Additional info:

Comment 7 errata-xmlrpc 2020-03-05 11:53:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0709


Note You need to log in before you can comment on or make changes to this bug.