Bug 1729876 - Hosted Domain should be set as required
Summary: Hosted Domain should be set as required
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Joe Caiani
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-15 08:05 UTC by Yadan Pei
Modified: 2019-10-16 06:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:29:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2035 None None None 2019-07-15 20:02:35 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:29:58 UTC

Description Yadan Pei 2019-07-15 08:05:05 UTC
Description of problem:
When adding Google IDP from console, Hosted Domain is set as an optional field while it's required when mapping method is `claim`

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-14-223254

How reproducible:
Always

Steps to Reproduce:
1. admin users logins and visit cluster OAuth configuration
2. Identity Providers -> Add -> Google
3. Fill in IDP Name, clientID, clientSecret and click Add

Actual results:
3. It returns error message
An error occurred
Error "Invalid value: "null": hostedDomain must be specified unless lookup is used" for field "spec.identityProviders[1].google.hostedDomain".
mappingMethod is hard coded as `claim` but `Hosted Domain` is set as optional field

Expected results:
3. `Hosted Domain` only can be set as optional when mappingMethod is set to `lookup` , our console make mappingMethod defaults to `claim` so we need set `Hosted Domain` as required field
Also it's much clear if we can some message on the page telling user mapping method is hardcoded as `claim` otherwise user don't know which mapping method is used until a IDP is finally created

Additional info:

Comment 1 Joe Caiani 2019-07-15 20:15:27 UTC
https://github.com/openshift/console/pull/2035

Comment 2 Samuel Padgett 2019-07-16 15:19:33 UTC
Just a quick note that we've decided not to explicitly call out the mapping method in the UI. Some discussion in the PR about it. It's an advanced option that you should rarely change. In this case since we've marked the field as required, I think it eliminates some of the confusion.

We will have to revisit this if we ever add edit capability to IDPs.

Comment 4 Yadan Pei 2019-07-18 06:47:10 UTC
Hosted Domain now is a required field, that's desired behavior

Verified on 4.2.0-0.nightly-2019-07-17-115118

Comment 5 errata-xmlrpc 2019-10-16 06:29:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.