Bug 1729882 - Weird Dropdown menu selection behaviour while selecting dates in Reports schedule
Summary: Weird Dropdown menu selection behaviour while selecting dates in Reports sche...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.11.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.11.0
Assignee: Milan Zázrivec
QA Contact: Parthvi Vala
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-15 08:34 UTC by Parthvi Vala
Modified: 2019-12-13 15:01 UTC (History)
7 users (show)

Fixed In Version: 5.11.0.18
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-13 15:01:04 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
Bug Demo (728.41 KB, video/webm)
2019-07-15 08:34 UTC, Parthvi Vala
no flags Details

Description Parthvi Vala 2019-07-15 08:34:38 UTC
Created attachment 1590631 [details]
Bug Demo

Description of problem:
Dropdown exhibits weird behavior while selecting dates on Schedules Edit/Create form.

Version-Release number of selected component (if applicable):
5.10

How reproducible:
Always

Steps to Reproduce:
1. Create/Edit a schedule.
2. Change `Starting Date`.
3. Change `Run`.
4. Check the value of `Starting Date`.
5. Click on `Starting Date` and check the date in the popped-up calendar.
6. Click somewhere else on the screen and check the value of `Starting Date`.

Actual results:
1.
2.
3.
4. Value of `Starting Date` changes to default, i.e. present date
5. The selected value of the date in the calendar will be the same as it was set in step 2.
6. Value of `Starting Date` changes back to what was set in step 2.

Expected results:
Value of `Starting Date` displayed must correspond to the value that is selected in Calendar. 

Additional info:
Same behavior on 5.9, 5.10 and 5.11.
Check video to understand the BZ better.

Comment 3 Milan Zázrivec 2019-07-31 15:25:49 UTC
The described issue is not a bug, it's a feature:
* if you select 'Hourly', the calendar date will be reset to now
* if you select anything else, the calendar date will be reset to next day (tomorrow)

Closing with notabug.

Comment 4 Parthvi Vala 2019-08-01 05:56:47 UTC
Hey Milan,

If you look at the bug demo I attached, I think you will agree that this is a bug.

Follow these steps to reproduce the bug:
1. Open the `Add a new Schedule` form.
2. Set the `Starting Date` to some date.
3. Change the `Run` to lets say, 'Weekly'.
4. See the `Starting Date`. It will be reset to tomorrow's date.
5. Click on the date to change it and observe the selected date in the calendar. It will the date you set in step 2.
6. Click anywhere outside the box. Date will be set to the one we set in step 2.

I think this behaviour is definitely a bug. The bug being, date visible in `Starting Date` is different to what is actually picked by the Calendar.

Let me know what you think.

Parthvi

Comment 5 Milan Zázrivec 2019-08-01 10:52:30 UTC
Yes, I guess it's worth a fix.

Comment 7 CFME Bot 2019-08-06 13:01:16 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:

https://github.com/ManageIQ/manageiq-ui-classic/commit/30092a56aef97a2af3385d30c8e520e13ca27e0e
commit 30092a56aef97a2af3385d30c8e520e13ca27e0e
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Thu Aug  1 06:48:06 2019 -0400
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Thu Aug  1 06:48:06 2019 -0400

    Update datepicker when start date changed

    https://bugzilla.redhat.com/show_bug.cgi?id=1729882

 app/controllers/report_controller/schedules.rb | 1 +
 1 file changed, 1 insertion(+)

Comment 8 CFME Bot 2019-08-06 15:35:56 UTC
New commit detected on ManageIQ/manageiq-ui-classic/ivanchuk:

https://github.com/ManageIQ/manageiq-ui-classic/commit/7c9d30602b562a8ed7e30718f80659970119f648
commit 7c9d30602b562a8ed7e30718f80659970119f648
Author:     Martin Povolny <mpovolny@redhat.com>
AuthorDate: Tue Aug  6 08:59:48 2019 -0400
Commit:     Martin Povolny <mpovolny@redhat.com>
CommitDate: Tue Aug  6 08:59:48 2019 -0400

    Merge pull request #5920 from mzazrivec/update_datepicker_when_start_date_changed

    Update datepicker when start date changed

    (cherry picked from commit c371d8462174aa346986dba09e27f70736884f1d)

    https://bugzilla.redhat.com/show_bug.cgi?id=1729882

 app/controllers/report_controller/schedules.rb | 1 +
 1 file changed, 1 insertion(+)

Comment 9 Parthvi Vala 2019-08-07 13:35:15 UTC
FIXED. Verified on 5.11.0.18.20190806180636_1dd6378.

Thanks for fixing this Milan :)


Note You need to log in before you can comment on or make changes to this bug.