Bug 1729953 - Unexpected error encountered while performing operations on VM's datastore page
Summary: Unexpected error encountered while performing operations on VM's datastore page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.10.7
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: GA
: 5.11.0
Assignee: Hilda Stastna
QA Contact: Ganesh Hubale
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-15 12:15 UTC by Ganesh Hubale
Modified: 2019-12-12 13:36 UTC (History)
6 users (show)

Fixed In Version: 5.11.0.18
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-12 13:36:50 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
Error page (60.63 KB, image/png)
2019-07-15 12:15 UTC, Ganesh Hubale
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:4199 0 None None None 2019-12-12 13:36:58 UTC

Description Ganesh Hubale 2019-07-15 12:15:47 UTC
Created attachment 1590722 [details]
Error page

Description of problem:
Unexpected error encountered while performing operations(Refresh Relationships and Power States, Perform Smartstate Analysis, Extract Running Processes) on VM.

Version-Release number of selected component (if applicable):
5.10.7.0.20190709151852_68f0bf9

How reproducible:
100%

Steps to Reproduce:
1. Add infrastructure provider(e.g: vsphere65)
2. Provision VM
3. Navigate to VM's details page and click on 'Datastores' from 'Relationships' table
4. Click on 'Managed VMs' from from 'Relationships' table
5. Select VM(Vm should be in 'on' state) and perform operations(Refresh Relationships and Power States, Perform Smartstate Analysis, Extract Running Processes) by selecting from 'configuration' dropdown

Actual results:
Unexpected error encountered

Expected results:
VM should be refreshed and flash message displayed.

Additional info:
- Working as expected in 5.9.9.1.20190304164243_28a581b
- Checked on old versions of 5.10z and this issue is reproducible
- This issue is reproducible on 5.11.0.14 too.

Comment 5 Hilda Stastna 2019-07-24 12:17:09 UTC
Note that the bug is also reproducible if you skip step 3,
so if you go directly to Compute > Infra > Datastores and
you display VMs thru some datastore's summary page.

Comment 6 Hilda Stastna 2019-07-24 15:25:16 UTC
Fixing https://github.com/ManageIQ/manageiq-ui-classic/pull/5867

Comment 7 Hilda Stastna 2019-07-25 09:41:33 UTC
Note that the bug is also present in the latest 5.11. and applies also to some other actions,
for example to some Power operations - this depends on the fact if an error flash message is
about to be rendered for a chosen operation or not. If not, this BZ is reproducible. If yes,
then nothing happens in the UI and there is a different problem (Render and/or redirect were
called multiple times), different parts of the code. I will open a separate BZ also for this
problem.

Also note that after the fix for this BZ will be merged, Extract Running Processes action still
may not work well - if there are some error flash messages which are about to be displayed - and
this is because of what I've written above (different issue - multiple redirecting).

Comment 8 Hilda Stastna 2019-07-25 13:20:11 UTC
Another note:
The fix for this BZ will probably fix also the https://bugzilla.redhat.com/show_bug.cgi?id=1732370
as the core of the problem is the same.

Comment 11 Ganesh Hubale 2019-07-31 16:15:34 UTC
Hi Hilda,

Please have a look at this asap.

This appliance will expire in two days.

Thanks, 
Ganesh

Comment 12 Hilda Stastna 2019-07-31 16:19:26 UTC
Hi Ganesh, 

thank you for the appliance and for reminding. I think I have everything I need.

Comment 13 CFME Bot 2019-08-05 10:56:42 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:

https://github.com/ManageIQ/manageiq-ui-classic/commit/21e06346084b2c562d91fba3456f360f6c164a0b
commit 21e06346084b2c562d91fba3456f360f6c164a0b
Author:     Hilda Stastna <hstastna@redhat.com>
AuthorDate: Wed Jul 24 09:57:13 2019 -0400
Commit:     Hilda Stastna <hstastna@redhat.com>
CommitDate: Wed Jul 24 09:57:13 2019 -0400

    Get record class while performing operations on VM's datastore page

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1729953

 app/controllers/application_controller/ci_processing.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 14 CFME Bot 2019-08-05 15:36:45 UTC
New commit detected on ManageIQ/manageiq-ui-classic/ivanchuk:

https://github.com/ManageIQ/manageiq-ui-classic/commit/86655602471bf71fe0cf35acbcf4cfa221671046
commit 86655602471bf71fe0cf35acbcf4cfa221671046
Author:     Milan Zázrivec <mzazrivec@redhat.com>
AuthorDate: Mon Aug  5 06:53:56 2019 -0400
Commit:     Milan Zázrivec <mzazrivec@redhat.com>
CommitDate: Mon Aug  5 06:53:56 2019 -0400

    Merge pull request #5867 from hstastna/Unexpected_error_VM_datastore_get_rec_cls

    Get proper record class while performing operations on Managed VMs of a chosen Datastore

    (cherry picked from commit dfab1f9d841e4dcc8b3faba3b83a9d8f7fd26c4e)

    https://bugzilla.redhat.com/show_bug.cgi?id=1729953

 app/controllers/application_controller/ci_processing.rb | 2 +-
 spec/controllers/application_controller/ci_processing_spec.rb | 22 +-
 2 files changed, 20 insertions(+), 4 deletions(-)

Comment 15 Ganesh Hubale 2019-08-08 13:18:13 UTC
Hi,

Checked on version: 5.10.8.0.20190729222758_e725e22

I can see that it is working for options(Refresh Relationships and Power States, Perform Smartstate Analysis, Extract Running Processes) 

But I am getting unexpected error for option: "Compare Selected items"

Hence failing this BZ.

Comment 16 Hilda Stastna 2019-08-08 13:49:08 UTC
Hi Ganesh,

first, there is no mention about 'Compare Selected items' operation in this BZ so I was not fixing this regarding this BZ.
Second, if you check the error message closely, you will find that that's completely different error so the problem is different:
We are missing routes for this operation. I already fixed this in a separate BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1733120.
Thank you.

Comment 17 Ganesh Hubale 2019-08-12 06:12:48 UTC
Fixed!

verifying on version: 5.11.0.18.20190806180636_1dd6378

Comment 19 errata-xmlrpc 2019-12-12 13:36:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4199


Note You need to log in before you can comment on or make changes to this bug.