Bug 1730016 - enable ktimer_lockless_check for realtime-virtual-host/guest tuned profiles
Summary: enable ktimer_lockless_check for realtime-virtual-host/guest tuned profiles
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.8
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Robin Hack
URL:
Whiteboard:
Depends On:
Blocks: 1672377 1690543 1734096 1817936
TreeView+ depends on / blocked
 
Reported: 2019-07-15 15:14 UTC by Marcelo Tosatti
Modified: 2020-12-17 14:08 UTC (History)
9 users (show)

Fixed In Version: tuned-2.11.0-8.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1734096 1817936 (view as bug list)
Environment:
Last Closed: 2020-03-31 19:12:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github redhat-performance/tuned/commit/25089296f312281502dbb3689cb24eb24c48ffeb 0 None None None 2020-09-15 03:25:35 UTC
Red Hat Product Errata RHBA-2020:1008 0 None None None 2020-03-31 19:12:38 UTC

Description Marcelo Tosatti 2019-07-15 15:14:36 UTC
RHEL-7.8 RT will include a feature to skip ktimersoftd wakeup. 

This feature is disabled by default and requires writing
1 to /sys/kernel/ktimer_lockless_check.

This should be enabled for tuned realtime profile.

Comment 2 Ondřej Lysoněk 2019-07-16 09:12:48 UTC
Do I understand it correctly that the sysfs file does not exist in the RHEL-7.7 realtime kernel, but is going to exist in the RHEL-7.8 RT kernel? What about RHEL-8? I'm just wondering whether we should put this change upstream or RHEL-7.8 only.

Comment 3 Marcelo Tosatti 2019-07-29 15:06:04 UTC
(In reply to Ondřej Lysoněk from comment #2)
> Do I understand it correctly that the sysfs file does not exist in the
> RHEL-7.7 realtime kernel, but is going to exist in the RHEL-7.8 RT kernel?
> What about RHEL-8? I'm just wondering whether we should put this change
> upstream or RHEL-7.8 only.

Its already upstream:

https://github.com/redhat-performance/tuned/commit/25089296f312281502dbb3689cb24eb24c48ffeb

So all is necessary is to backport it to RHEL-7.8 (and include it in RHEL-8 as well).

Comment 4 Ondřej Lysoněk 2019-07-29 15:31:32 UTC
Oh, ok.

Comment 8 Luiz Capitulino 2020-03-24 20:41:09 UTC
Business justification (customer impact; how would the defect impact customers’ business? why is it not possible to wait for a fix in Y-Stream?):

This fix is necessary for the current NFV deployment with
Altiostar to achieve the required latency.

How many customers are impacted by this defect?

Right now it is only Altiostar, but they could deploy it
more customers in the coming weeks.

When was the defect introduced in this major version of RHEL? Is it a regression?



What is the minimal patch set to fix this bug? (link, git commit,...)

Comment 9 Tomáš Hozza 2020-03-25 08:38:40 UTC
(In reply to Luiz Capitulino from comment #8)
> Business justification (customer impact; how would the defect impact
> customers’ business? why is it not possible to wait for a fix in Y-Stream?):
> 
> This fix is necessary for the current NFV deployment with
> Altiostar to achieve the required latency.

Hi Luiz.

Can you please elaborate on what is the impact of not achieving the required latency? Especially in the situation without this fix.

Thanks.

Comment 10 Jaroslav Škarvada 2020-03-25 17:27:09 UTC
(In reply to Luiz Capitulino from comment #8)
> Business justification (customer impact; how would the defect impact
> customers’ business? why is it not possible to wait for a fix in Y-Stream?):
> 
> This fix is necessary for the current NFV deployment with
> Altiostar to achieve the required latency.
> 
> How many customers are impacted by this defect?
> 
> Right now it is only Altiostar, but they could deploy it
> more customers in the coming weeks.
> 
> When was the defect introduced in this major version of RHEL? Is it a
> regression?
> 
It's for the backported kernel patch. It's not regression.

> 
> 
> What is the minimal patch set to fix this bug? (link, git commit,...)
>
https://github.com/redhat-performance/tuned/commit/25089296f312281502dbb3689cb24eb24c48ffeb

Comment 11 Luiz Capitulino 2020-03-25 18:14:04 UTC
(In reply to Tomáš Hozza from comment #9)
> (In reply to Luiz Capitulino from comment #8)
> > Business justification (customer impact; how would the defect impact
> > customers’ business? why is it not possible to wait for a fix in Y-Stream?):
> > 
> > This fix is necessary for the current NFV deployment with
> > Altiostar to achieve the required latency.
> 
> Hi Luiz.
> 
> Can you please elaborate on what is the impact of not achieving the required
> latency? Especially in the situation without this fix.

We may loose some telco businesses.

The NFV field team has made a RT OSP deployment that's been
used by some telco companies to evaluate our solution for NFV.

This deployment was having latency spikes, which means the
current evaluation is failing. We debugged it down and this
BZ is one of the fixes necessary for 7.7.z in order to make
the evaluation pass.

Comment 17 errata-xmlrpc 2020-03-31 19:12:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1008


Note You need to log in before you can comment on or make changes to this bug.