Bug 1730026 - Some hammer docker commands fail with uninitialized constant HammerCLIKatello::LifecycleEnvironmentNameResolvable
Summary: Some hammer docker commands fail with uninitialized constant HammerCLIKatello...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer - Content
Version: 6.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: 6.6.0
Assignee: Martin Bacovsky
QA Contact: Peter Dragun
URL:
Whiteboard:
: 1737497 (view as bug list)
Depends On:
Blocks: 1713222 1737463
TreeView+ depends on / blocked
 
Reported: 2019-07-15 15:41 UTC by Mirek Zalewski
Modified: 2019-11-15 19:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-22 13:30:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 27397 'Normal' 'Closed' 'Some hammer docker commands fail with uninitialized constant HammerCLIKatello::LifecycleEnvironmentNameResolvable' 2019-11-15 19:45:08 UTC
Red Hat Product Errata RHBA-2019:3175 None None None 2019-10-22 13:32:42 UTC

Description Mirek Zalewski 2019-07-15 15:41:35 UTC
Some hammer commands fail with:

Error: uninitialized constant HammerCLIKatello::LifecycleEnvironmentNameResolvable
Did you mean?  HammerCLIKatello::LifecycleEnvironmentNameMapping


This definitely happens on `hammer docker manifest list`, but I am yet to discover full scope of the problem.


Version:
Satellite 6.6.0 snap 11
pulp-server-2.19.1-1.el7sat.noarch
satellite-6.6.0-5.beta.el7sat.noarch
katello-3.12.0-1.el7sat.noarch
foreman-1.22.0.9-1.el7sat.noarch
tfm-rubygem-hammer_cli_katello-0.18.0.2-1.el7sat.noarch
tfm-rubygem-hammer_cli-0.17.1-2.el7sat.noarch

Comment 3 Martin Bacovsky 2019-07-23 22:52:12 UTC
Created redmine issue https://projects.theforeman.org/issues/27397 from this bug

Comment 4 Martin Bacovsky 2019-07-23 23:17:01 UTC
It seems only 'hammer docker manifest list' and 'hammer docker tag list` commands are affected

Comment 5 Bryan Kearney 2019-07-24 00:02:19 UTC
Upstream bug assigned to mbacovsk@redhat.com

Comment 6 Bryan Kearney 2019-07-24 10:02:10 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/27397 has been resolved.

Comment 7 Martin Bacovsky 2019-07-26 16:55:29 UTC
Moving to ON_QA as the related patch was included in Snap 13

Comment 8 Martin Bacovsky 2019-08-08 12:18:17 UTC
*** Bug 1737497 has been marked as a duplicate of this bug. ***

Comment 9 Peter Dragun 2019-08-29 09:18:00 UTC
Verified on Sat 6.6 snap 17. Using commands 'hammer docker manifest list' and 'hammer docker tag list'. Both ended without error.

Comment 11 errata-xmlrpc 2019-10-22 13:30:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3175


Note You need to log in before you can comment on or make changes to this bug.