Bug 173004 - Network freeze: ifdown/ifup sequence needed to clear network hang
Network freeze: ifdown/ifup sequence needed to clear network hang
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-11 20:02 EST by Richard Woodruff
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-09 16:20:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Woodruff 2005-11-11 20:02:10 EST
Description of problem:

 Network locks up on Dell Precision using E1000 driver.  After some use 
networking locks up.  The system will not respond to pings.  At a console window
on the machine a ifdown then ifup will clear the condition and networking starts
to work again.

Version-Release number of selected component (if applicable):

 started on 2.6.14-1.1637_FC4smp (and 638)

How reproducible:

Start up DIA on another machine.  Start editing a large diagram, zoom in till
large.  System locks up.  Now go to console and tweak networking and it
restarts.  At the console some gnome apps don't respond until the network
up/down sequence also.

Not very focused, but its something which didn't happen using eariler kernels.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John W. Linville 2005-11-30 10:30:13 EST
The fedora-netdev kernels are available here: 
 
   http://people.redhat.com/linville/kernels/fedora-netdev/ 
 
Please give those a try and post the results here...thanks! 
Comment 2 Richard Woodruff 2005-11-30 12:12:00 EST
I booted the 2.6.14-1.1637_FC4.netdev.2 kernel and the same hang up happens.  
In the two times I tried, it actually happned faster, almost immediatly.

Using the 2.6.14-1.1644_FC4 it still happens but may take five minutes to lock 
up.

In general the senerio I use to repoduce it is to use an Exceed Xterm on a Win 
System displaying from my FC4 box.  I can understand and expect the Windows 
side windows to freeze up, but not the Linux box's net usability.  I suppose I 
could run ethereal to see if one side was spewing packets... Top on the linux 
side doesn't show anything strange. 
Comment 3 John W. Linville 2005-12-02 13:10:01 EST
Please attach the output of running sysreport soon after such a 
lock-up...thanks! 
Comment 4 John W. Linville 2006-01-09 16:20:42 EST
Closed due to lack of response.  Please reopen when the requested information 
becomes available...thanks! 

Note You need to log in before you can comment on or make changes to this bug.