Bug 1730085 - pre-upgrade Repos validations fail on permission error
Summary: pre-upgrade Repos validations fail on permission error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 15.0 (Stein)
Assignee: Gaël Chamoulaud
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks: 1462840
TreeView+ depends on / blocked
 
Reported: 2019-07-15 19:18 UTC by Amit Ugol
Modified: 2019-09-27 10:43 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-validations-10.5.1-0.20190820150507.77085bb.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:23:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 670991 None master: MERGED tripleo-validations: Use ansible_pkg_mgr fact instead of hardcoding yum command (I5f9ea00d8c2c438b16d28f7de91c2ac79fd012... 2019-08-26 13:51:58 UTC
OpenStack gerrit 671211 None stable/stein: MERGED tripleo-validations: Use ansible_pkg_mgr fact instead of hardcoding yum command (I5f9ea00d8c2c438b16d28f7de91c2ac79fd012... 2019-08-26 13:52:04 UTC
OpenStack gerrit 672722 None master: MERGED tripleo-validations: Correct "repos" validation and adds Molecule tests (Ib46f5993eeac6ec39a603da3b8e943c960d7c52d) 2019-08-26 13:52:11 UTC
OpenStack gerrit 673993 None stable/stein: MERGED tripleo-validations: Correct "repos" validation and adds Molecule tests (Ib46f5993eeac6ec39a603da3b8e943c960d7c52d) 2019-08-26 13:52:18 UTC
Red Hat Product Errata RHEA-2019:2811 None None None 2019-09-21 11:24:11 UTC

Description Amit Ugol 2019-07-15 19:18:51 UTC
Description of problem:
"repos" validation returns failure because /var/cache/dnf/expired_repos.json can't be touched.

Version-Release number of selected component (if applicable):
openstack-tripleo-validations-10.4.1-0.20190701170405.10b4d77.el8ost.noarch

How reproducible:
100%

Steps to Reproduce:
Run the repos validation.

Actual results:
[FAILED] - repos
    Task 'repos : List repositories' failed:
    Host: compute-1
    Message: Command `yum repolist -v` exited with code: 1: non-zero return code
    stdout:
        Loaded plugins: builddep, changelog, config-manager, copr, debug, debuginfo-install, download, generate_completion_cache, needs-restarting, playground, product-id, repoclosure, repodiff, repograph, repomanage, reposync, subscription-manager, uplo
adprofile
        Not root, Subscription Management repositories not updated
        DNF version: 4.0.9
        cachedir: /var/cache/dnf
        ...
        trim
        ...
    stderr:
        [Errno 13] Permission denied: '/var/cache/dnf/expired_repos.json'
    Task 'repos : List repositories' failed:
    Host: controller-1
    Message: Command `yum repolist -v` exited with code: 1: non-zero return code

Expected results:
Test should work fully.

Comment 17 errata-xmlrpc 2019-09-21 11:23:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.