Bug 1730114 - vfd cannot be attached from Data Domain (ISO domains deprecated)
Summary: vfd cannot be attached from Data Domain (ISO domains deprecated)
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.3.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Nobody
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-15 21:37 UTC by amashah
Modified: 2019-11-13 21:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-04 18:33:01 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 4284631 Configure None RHV - virtio-win.vfd cannot be attached via Run Once if stored on a Data Storage Domain 2019-07-16 18:59:31 UTC

Description amashah 2019-07-15 21:37:19 UTC
Description of problem:

Unable to attach vfd's on Data Storage Domains via 'Run Once'.

In previous versions of RHV, ISO domains were used to upload vfd's such as virtio-win.vfd. In RHV 4.3, ISO domains are being deprecated as you can upload ISO's to Data SD's now. While vfd files can be uploaded to Data SD's, you are unable to attach them to VM's via 'Run Once' -- any uploaded vfd's to Data SD's are not listed under Attach Floppy. 

Version-Release number of selected component (if applicable):
4.3.4

How reproducible:
100%

Steps to Reproduce:
1. Upload virtio-win.vfd to a data SD
2. Using 'Run Once' feature, try to attach floppy to a VM
3. No vfd's are listed

Actual results:
Cannot attach vfd via 'Run Once' / Attach Floppy.


Expected results:
Be able to attach vfd's that live on Data SD's because ISO domains are deprecated.

Additional info:

You can attach virtio-win.iso but this is not enough if you need to install the OS from an ISO and simultaneously have virtio drivers attached. 

Additionally, the documentation [1] will need to be updated as the current documentation tells you to use the engine-iso-uploader tool to upload this to an ISO domain. This should be adjusted as the tool and the SD type are no longer supported.

[1] https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.3/html/administration_guide/sect-the_iso_uploader_tool

Comment 5 Daniel Gur 2019-08-28 13:13:34 UTC
sync2jira

Comment 6 Daniel Gur 2019-08-28 13:17:48 UTC
sync2jira

Comment 8 Ryan Barry 2019-11-04 18:33:01 UTC
Floppy support is gone in 4.4, since upstream is slated for removal also.

This will be CLOSED - WONTFIX, since qemu will remove it, and we cannot re-implement from RHV

Comment 9 Marina Kalinin 2019-11-13 21:37:50 UTC
Replacement for vfd and floppy drivers in RHV 4.4 is coming from this bz#1306586:

Feature: Replace the floppy device with an additional CDROM device for sysprep installation for Compatibility Versions 4.4 and later. 

Reason: To deprecate floppy support which has resulted in many issues.

Result: An additional CDROM device shall be used to replace the floppy drive for versions 4.4 and later.


Note You need to log in before you can comment on or make changes to this bug.