Bug 1730145 - subscription-manager fails: HTTP error (422 - Unknown): Please unregister or remove hosts which match this host before registering: <hostname>
Summary: subscription-manager fails: HTTP error (422 - Unknown): Please unregister or ...
Keywords:
Status: CLOSED DUPLICATE of bug 1730146
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Jonathon Turel
QA Contact: Lai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-16 01:37 UTC by Jonathon Turel
Modified: 2019-07-16 17:26 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-16 17:26:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 27251 Normal Closed subscription-manager fails: HTTP error (422 - Unknown): Please unregister or remove hosts which match this host before r... 2020-01-25 16:42:10 UTC

Description Jonathon Turel 2019-07-16 01:37:20 UTC
Foreman: 1.22.0
Katello: 3.12.0

While I've been working towards migrating from Spacewalk/RHSat5, I've been rebuilding hosts left & right.  I've been making changes to the host records in TFM/Katello, triggering a host build, downloading a boot ISO, and rebuilding in place.  The redhat-register provisioning template has been able to re-register and connect the host record.

Now, I'm finding that this registration is failing.  Adding a --force option doesn't seem to make a difference:

root@<host> ~]# subscription-manager register --force --name="<FQhostname>" --org='Organization' --activationkey='dev-centos7,dev-mondorescue-el7'
HTTP error (422 - Unknown): Please unregister or remove hosts which match this host before registering: <FQhostname>
[root@<hostname> ~]# subscription-manager unregister
This system is currently not registered.
[root@<hostname> ~]# subscription-manager register --force --name="<FQhostname>" --org='Land_O_Lakes' --activationkey='dev-centos7,dev-mondorescue-el7'
HTTP error (422 - Unknown): Please unregister or remove hosts which match this host before registering: <FQhostname>

jturel suggested running "hammer host subscription unregister host <FQhostname>" on the TFM/Katello host prior to the rebuild.  This work-around now lets me successfully register the host in place.

What other data or logs can I supply?  /var/log/rhsm/* doesn't seem to supply much detail beyond the above.

Comment 1 Jonathon Turel 2019-07-16 01:37:22 UTC
Created from redmine issue https://projects.theforeman.org/issues/27251

Comment 4 Bryan Kearney 2019-07-16 02:07:56 UTC
Upstream bug assigned to jturel@redhat.com

Comment 5 Brad Buckingham 2019-07-16 17:26:04 UTC

*** This bug has been marked as a duplicate of bug 1730146 ***


Note You need to log in before you can comment on or make changes to this bug.