Bug 1730241 - Support tagging resources and performing actions based on those tags
Summary: Support tagging resources and performing actions based on those tags
Keywords:
Status: CLOSED DUPLICATE of bug 1684676
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: pcs
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Tomas Jelinek
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-16 09:22 UTC by Chris Feist
Modified: 2019-07-16 11:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-16 11:05:14 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Chris Feist 2019-07-16 09:22:52 UTC
Pacemaker allows tagging resources, but this isn't currently implemented in pcs.

Customers would like the ability to tag resources and then run commands on all resources with those tags.  To start with we would be looking at the following commands:
1.  View the status of resources with a specific tag
2.  Enable/disable resources with a specific tag
3.  Manage/Unmanage
4.  Move/unmove
5.  Anything else that would make sense to do to a group of resources

Info about pacemaker tagging:
https://clusterlabs.org/pacemaker/doc/en-US/Pacemaker/1.1/html/Pacemaker_Explained/_tagging_configuration_elements.html

Comment 1 Tomas Jelinek 2019-07-16 11:05:14 UTC

*** This bug has been marked as a duplicate of bug 1684676 ***


Note You need to log in before you can comment on or make changes to this bug.