Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1730242 - unable to see ibus-sayura in Region panel
Summary: unable to see ibus-sayura in Region panel
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-sayura
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-16 09:28 UTC by Parag Nemade
Modified: 2020-09-22 09:27 UTC (History)
7 users (show)

Fixed In Version: ibus-sayura-1.3.2-16.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-22 09:27:09 UTC
Type: Bug


Attachments (Terms of Use)

Description Parag Nemade 2019-07-16 09:28:24 UTC
Description of problem:
On Fedora 30 updated Silverblue system, I layered ibus-sayura package. Then tried to add it via Region panel. I cannot see it listed there.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Layer ibus-sayura package
2. reboot or you can ibus restart
3. try to add Sayura input using Region panel

Actual results:
There is no entry for Sayura in Region panel

Expected results:
It should allow to select Sayura

Additional info:
As I did not see Sayura, I executed "ibus write-cache"

Then, I executed
[parag@f30sb ~]$ ibus read-cache|grep -i sayura
            <description>Sayura Component</description>
            <exec>/usr/libexec/ibus-engine-sayura --ibus</exec>
            <textdomain>ibus-sayura</textdomain>
                <path mtime="0" >/usr/share/ibus/component/sayura.xml</path>
                        <name>sayura</name>
                        <longname>Sayura</longname>
                        <description>Sayura Input Method</description>
                        <icon>/usr/share/ibus-sayura/icons/ibus-sayura.png</icon>


Then,
[parag@f30sb ~]$ ibus list-engine|grep -i sayura
no output for above command

Comment 1 Parag Nemade 2019-07-16 12:20:25 UTC
[UPDATE]

So after rebooting machine now, I can use ibus-sayura and also got output
[parag@f30sb ~]$ ibus list-engine|grep -i sayura
  sayura - Sayura
[parag@f30sb ~]$ 

So, what can be done to have this "ibus write-cache" not to be executed manually?

Comment 2 fujiwara 2019-07-17 03:25:33 UTC
(In reply to Parag Nemade from comment #0)
> 2. reboot or you can ibus restart

(In reply to Parag Nemade from comment #1)
> [UPDATE]
> So after rebooting machine now, I can use ibus-sayura and also got output

So the description is not accurate?
Th reboot does not cause your issue but `ibus restart` causes your issue?

`ibus write-cache` writes the cache in the local directory.
`ibus list-engine` pulls the engines from ibus-daemon which loads in the local directory.
I.e. you seems to have the different caches between the container and host.

And I also guess `ibus restart` does not update the PID of the ibus-daemon because you run `ibus restart` in the container.
I think `ibus restart` does not allow in the container so you need to log out and in the session again to update the caches in the host directory.
I also guess your desktop is GNOME.

Or a risk way would be to kill ibus-daemon and gnome-shell restart ibus-daemon.
One workaround would be to create a .desktop file of `ibus restart` and click the menu item from application menu.

Comment 3 Parag Nemade 2019-07-17 05:35:43 UTC
So we discussed this on IRC and fix is to add %post scriptlet to have cache updated automatically when package gets installed on Silverblue.

Comment 4 Parag Nemade 2019-07-18 09:32:35 UTC
I updated my F31 Silverblue system and saw that local cache got updated but no system cache file at all.
also "ibus read-cache" command does not show Sayura in output.

Comment 5 Ben Cotton 2019-08-13 16:55:40 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 6 Ben Cotton 2019-08-13 18:57:01 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 7 Jens Petersen 2020-09-22 06:26:03 UTC
I believe this is already fixed in ibus, no?

Comment 8 Parag Nemade 2020-09-22 09:27:09 UTC
Yes this is fixed now. Just tested in my F33 Silverblue VM and I can add Sayura and use it immediately without any issue.


Note You need to log in before you can comment on or make changes to this bug.