Bug 1730279 - source policy format (mentioned in man pages) is no longer supported by setools
Summary: source policy format (mentioned in man pages) is no longer supported by setools
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: setools
Version: 8.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 8.1
Assignee: Vit Mojzis
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-16 11:41 UTC by Milos Malik
Modified: 2019-11-05 22:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 22:17:53 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3574 None None None 2019-11-05 22:18:02 UTC

Description Milos Malik 2019-07-16 11:41:02 UTC
Description of problem:
 * man pages of various setools commands say that source policy format is supported - this is NOT correct

Version-Release number of selected component (if applicable):
setools-console-4.2.1-3.el8.x86_64

How reproducible:
 * always

Steps to Reproduce:
1. get a RHEL-8 machine
# man sediff seinfo sesearch | col -b | grep -A 2 source:
	      source:
		     A single text file containing a monolithic policy source.
		     This file is usually named policy.conf.
--
	      source:
		     A single text file containing a monolithic policy source.
		     This file is usually named policy.conf.
--
	      source:
		     A single text file containing a monolithic policy source.
		     This file is usually named policy.conf.
#

Expected results:
 * only binary policy format is supported

Comment 1 Milos Malik 2019-07-16 11:44:17 UTC
Here is the relevant change between 4.2.1 and 4.2.2 versions:

 * https://github.com/SELinuxProject/setools/commit/aaf5273a96a85304e6bdd1c8c9ea113fa5b82e49

Comment 14 errata-xmlrpc 2019-11-05 22:17:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3574


Note You need to log in before you can comment on or make changes to this bug.