Bug 1730390 - Operating System dropdown in VM Wizard sometimes reloads content after being opened
Summary: Operating System dropdown in VM Wizard sometimes reloads content after being ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Container Native Virtualization (CNV)
Classification: Red Hat
Component: User Experience
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 2.1.0
Assignee: Filip Krepinsky
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-16 15:12 UTC by Radim Hrazdil
Modified: 2019-11-04 15:06 UTC (History)
3 users (show)

Fixed In Version: 4.2.0-0.nightly-2019-08-15-073735
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-04 15:06:17 UTC
Target Upstream Version:


Attachments (Terms of Use)
video sample (1.49 MB, application/x-matroska)
2019-07-16 15:12 UTC, Radim Hrazdil
no flags Details

Description Radim Hrazdil 2019-07-16 15:12:37 UTC
Created attachment 1591091 [details]
video sample

Description of problem:
I have encountered an issue with Operating System dropdown in VM Wizard (in the basic settings tab).

The issue is that sometimes when the dropdown is opened, it contains only few options, as if common templates were not installed. However, after some time, the content of the dropdown is reloaded and all options are displayed appropriately.

All the OS types should be loaded at the time the VM Wizard is opened.

See attached video sample, especially the attempt after 0:20, in which the loading takes significant amount of time.

Version-Release number of selected component (if applicable):


How reproducible:
around 50%, maybe less

Steps to Reproduce:
1. Open VM Wizard
2. set provision method
3. open OS dropdown

Actual results:
Sometimes the content of the dropdown is reloaded quite long after the dropdown is opened 

Expected results:
The dropdown should have defined up to date content at the time VM Wizard is opened and loaded. 

Additional info:
Not an issue from automation perspective, but it doesn't look good from user point of view

Comment 2 Radim Hrazdil 2019-08-20 13:45:57 UTC
Verified that OS dropdown is now disabled until content is preloaded.
INSTALLER_VERSION=4.2.0-0.nightly-2019-08-15-073735
HCO-v2.1.0-13


Note You need to log in before you can comment on or make changes to this bug.