Bug 1730391 - RedHat OpenShift 4.1 Installation fails
Summary: RedHat OpenShift 4.1 Installation fails
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RHCOS
Version: 4.1.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 4.1.z
Assignee: Steve Milner
QA Contact: Micah Abbott
URL:
Whiteboard:
Depends On:
Blocks: 1186913
TreeView+ depends on / blocked
 
Reported: 2019-07-16 15:13 UTC by umesh_sunnapu
Modified: 2019-08-08 16:00 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-08 16:00:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
RHCOS VM Stuck during boot with the error seen in the image (8.24 KB, image/png)
2019-07-16 15:13 UTC, umesh_sunnapu
no flags Details

Description umesh_sunnapu 2019-07-16 15:13:02 UTC
Created attachment 1591092 [details]
RHCOS VM Stuck during boot with the error seen in the image

Description of problem:

Version-Release number of the following components:
openshift-install-linux-4.1.4.tar.gz

How reproducible:

After following the guidelines specified in https://access.redhat.com/documentation/en-us/openshift_container_platform/4.1/html/installing/installing-on-vsphere to created Red Hat Enterprise Linux CoreOS (as specified in step 4.1.9 in the reference doc), RHCOS VM does not get created. 

Actual results:
Please check the Image attached to see where the boot process gets stuck and I could not go any further.

Expected results:

Smooth installation of RHCOS VM.

Comment 2 Steve Milner 2019-07-26 19:49:05 UTC
Thanks for the report. Looking at the attached file it seems as if /etc/iscsi/initiatorname.iscsi is not present (or possibly unreadable). I pulled down the related image and the file does exist and seems to be readable after the generation unit runs:

[core@coreos ~]$ ls -lahZ /etc/iscsi/initiatorname.iscsi 
-rw-rw-r--. 1 root root system_u:object_r:etc_t:s0 50 Jul 26 19:29 /etc/iscsi/initiatorname.iscsi
[core@coreos ~]$

but it's possible the unit is racing with the file generation.

Comment 4 Steve Milner 2019-07-29 18:22:16 UTC
It looks like /etc/iscsi/initiatorname.iscsi is not available in early boot which is causing the issue. I've opened https://bugzilla.redhat.com/show_bug.cgi?id=1734144 with our storage folks for review.

Comment 12 Steve Milner 2019-08-08 16:00:47 UTC
From my understanding this issue ended up getting resolved and the fix looks to be about adding in more documentation around specific installation types. I've raised this with our docs folks.

Marking as closed. If there is still an issue please do reopen!


Note You need to log in before you can comment on or make changes to this bug.