Bug 1730497 - OC deployment without any customization fails with: 'fatal: [undercloud]: FAILED! => {"censored": "the output has been hidden due to the fact that 'no_log: true' was specified for this result", "changed": true'
Summary: OC deployment without any customization fails with: 'fatal: [undercloud]: FAI...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Cédric Jeanneret
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-16 22:16 UTC by Alexander Chuzhoy
Modified: 2019-07-26 13:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-26 13:55:31 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alexander Chuzhoy 2019-07-16 22:16:21 UTC
OC deployment without any customization fails with: 'fatal: [undercloud]: FAILED! => {"censored": "the output has been hidden due to the fact that 'no_log: true' was specified for this result", "changed": true'


Environment:
openstack-tripleo-heat-templates-10.6.1-0.20190713150434.2871ce0.el8ost.noarch
python3-tripleoclient-11.4.1-0.20190705110410.14ae053.el8ost.noarch


Steps to reproduce:
Attempted to deploy OC without network isolation using the following command:
openstack overcloud deploy --templates \
--ntp-server clock.redhat.com \
-e /home/stack/nodes_data.yaml \
-e ~/containers-prepare-parameter.yaml 



(undercloud) [stack@undercloud ~]$ cat nodes_data.yaml 
parameter_defaults:
    ControllerCount: 3
    OvercloudControlFlavor: control
    ComputeCount: 1
    OvercloudComputeFlavor: compute


Result:
overcloud deployment fails with:
2019-07-17 01:07:12,611 p=481 u=mistral |  TASK [Write role data file] ****************************************************
2019-07-17 01:07:12,611 p=481 u=mistral |  Wednesday 17 July 2019  01:07:12 +0300 (0:00:01.346)       0:07:13.973 ******** 
2019-07-17 01:07:13,629 p=481 u=mistral |  changed: [undercloud] => {"changed": true, "checksum": "e77cfb4314ff0bdb16909b0d52472631bf43f786", "dest": "/tmp/ansible.6esx1854-role-data", "gid": 1002, "group": "tripleo-admin", "md5sum": "9d2349a6ee8bcb856c4dce43ec3699d0", "mode": "0600", "owner": "tripleo-admin", "secontext": "unconfined_u:object_r:user_tmp_t:s0", "size": 14143, "src": "/tmp/ansible-tripleo-admin/ansible-tmp-1563314832.6534789-3768531410985/source", "state": "file", "uid": 1001}
2019-07-17 01:07:13,745 p=481 u=mistral |  TASK [Run tripleo-container-image-prepare logged to /var/log/tripleo-container-image-prepare.log] ***
2019-07-17 01:07:13,745 p=481 u=mistral |  Wednesday 17 July 2019  01:07:13 +0300 (0:00:01.134)       0:07:15.107 ******** 
2019-07-17 01:07:41,724 p=481 u=mistral |  fatal: [undercloud]: FAILED! => {"censored": "the output has been hidden due to the fact that 'no_log: true' was specified for this result", "changed": true}
2019-07-17 01:07:41,726 p=481 u=mistral |  NO MORE HOSTS LEFT *************************************************************
2019-07-17 01:07:41,728 p=481 u=mistral |  PLAY RECAP *********************************************************************
2019-07-17 01:07:41,728 p=481 u=mistral |  overcloud-controller-0     : ok=161  changed=107  unreachable=0    failed=0    skipped=292  rescued=0    ignored=1   
2019-07-17 01:07:41,728 p=481 u=mistral |  overcloud-controller-1     : ok=161  changed=107  unreachable=0    failed=0    skipped=292  rescued=0    ignored=1   
2019-07-17 01:07:41,728 p=481 u=mistral |  overcloud-controller-2     : ok=161  changed=107  unreachable=0    failed=0    skipped=292  rescued=0    ignored=1   
2019-07-17 01:07:41,729 p=481 u=mistral |  overcloud-novacompute-0    : ok=115  changed=60   unreachable=0    failed=0    skipped=338  rescued=0    ignored=1   
2019-07-17 01:07:41,729 p=481 u=mistral |  undercloud                 : ok=8    changed=4    unreachable=0    failed=1    skipped=0    rescued=0    ignored=0   
2019-07-17 01:07:41,730 p=481 u=mistral |  Wednesday 17 July 2019  01:07:41 +0300 (0:00:27.984)       0:07:43.091 ******** 
2019-07-17 01:07:41,730 p=481 u=mistral |  =============================================================================== 
(undercloud) [stack@undercloud ~]$ 




The nodes in ironic use staging-ovirt driver, but the stack was deployed successfully:

(undercloud) [stack@undercloud ~]$ openstack stack list
+--------------------------------------+------------+----------------------------------+-----------------+----------------------+--------------+
| ID                                   | Stack Name | Project                          | Stack Status    | Creation Time        | Updated Time |
+--------------------------------------+------------+----------------------------------+-----------------+----------------------+--------------+
| 163b195e-878a-4e05-8661-9b87ff7aa9ec | overcloud  | 83435ced56df4ebf9d2b95f0172585cc | CREATE_COMPLETE | 2019-07-16T21:41:33Z | None         |
+--------------------------------------+------------+----------------------------------+-----------------+----------------------+--------------+


(undercloud) [stack@undercloud ~]$ openstack baremetal node show compute-0 -f value -c driver
staging-ovirt

Comment 2 Cédric Jeanneret 2019-07-17 07:07:48 UTC
Hello!

care to share the /var/log/tripleo-container-image-prepare.log from the undercloud? It's apparently not in the sosreport..

Cheers,

C.

Comment 3 Cédric Jeanneret 2019-07-17 11:44:15 UTC
(For info, I've just pushed https://github.com/sosreport/sos/pull/1729 in order to provide the missing log in sosreport. Hopefully it will get merged soon and be shipped to the relevant systems)

Comment 7 Alexander Chuzhoy 2019-07-26 13:55:31 UTC
The issue was related to https://bugzilla.redhat.com/show_bug.cgi?id=1707824


Note You need to log in before you can comment on or make changes to this bug.