Bug 1730540 - The example query would always added to the first query-input field
Summary: The example query would always added to the first query-input field
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.2.0
Assignee: Andrew Pickering
QA Contact: Viacheslav
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-17 05:36 UTC by Junqi Zhao
Modified: 2019-10-16 06:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:29:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
The example query would always added to the first query-input field (63.86 KB, image/png)
2019-07-17 05:39 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2513 None None None 2019-08-28 05:02:19 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:32:03 UTC

Description Junqi Zhao 2019-07-17 05:36:57 UTC
Description of problem:
login cluster console as cluster-admin, and click "Add Query" to add one query-input field, then the mouse point is at the 2nd query-input field, click "Insert Example Query" button, then the example metrics expression is added to the first query-input field, not the 2nd one. 

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-16-173254

How reproducible:
Alwasy

Steps to Reproduce:
1. See the description
2.
3.

Actual results:
The example query would always added to the first query-input field

Expected results:


Additional info:

Comment 1 Junqi Zhao 2019-07-17 05:39:07 UTC
Created attachment 1591281 [details]
The example query would always added to the first query-input field

Comment 3 Viacheslav 2019-08-29 13:11:11 UTC
bug still observed.
always try to insert example query to the first line.

4.2.0-0.nightly-2019-08-28-235925

Comment 4 Samuel Padgett 2019-08-29 13:25:19 UTC
This build does not contain the fix.

Comment 6 Junqi Zhao 2019-09-03 01:53:11 UTC
click "Add Query" to add a few query-input fields, the example metrics expression would add to the query-input field where the mouse is focused, and the example metrics would run immediately

payload: 4.2.0-0.nightly-2019-09-02-172410

Comment 7 errata-xmlrpc 2019-10-16 06:29:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.