Bug 1730643 - REGRESSION: Egg 3.0.110 does not start on standard RHEL6/RHEL7 anymore due to cgroups check
Summary: REGRESSION: Egg 3.0.110 does not start on standard RHEL6/RHEL7 anymore due to...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: insights-client
Version: 6.10
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Richard Brantley
QA Contact: Jeff Needle
URL:
Whiteboard:
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2019-07-17 09:10 UTC by Peter Vreman
Modified: 2019-08-13 15:00 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-13 14:59:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 4289381 Troubleshoot None insights-client fails with Memory "cgroup is disabled; insights-client will not run" 2019-07-17 13:38:14 UTC
Red Hat Product Errata RHBA-2019:2474 None None None 2019-08-13 15:00:03 UTC

Description Peter Vreman 2019-07-17 09:10:59 UTC
Description of problem:
On RHEL6 the default is not to use cgroups.
The new Egg 3.0.110 has a check for cgroups

Running the Egg on RHEL6.10
--------
$ sudo insights-client --verbose
2019-07-17 08:58:38,390    DEBUG insights.client.client Logging initialized
2019-07-17 08:58:38,391    DEBUG root Loaded initial egg: /var/lib/insights/last_stable.egg/insights
2019-07-17 08:58:38,391    DEBUG insights.client /usr/bin/gpg --verify --keyring /etc/insights-client/redhattools.pub.gpg /var/lib/insights/last_stable.egg.asc /var/lib/insights/last_stable.egg
2019-07-17 08:58:38,404    DEBUG insights.client GPG return code: 0
2019-07-17 08:58:38,731    DEBUG insights.client.client Logging initialized
2019-07-17 08:58:38,731    DEBUG insights.client.auto_config Trying to autoconfigure...
2019-07-17 08:58:38,734    DEBUG rhsm.https Using m2crypto wrappers to provide httplib and ssl
...
2019-07-17 08:58:39,028    DEBUG insights.client.utilities Client version: 3.0.3-3.el6
2019-07-17 08:58:39,029    DEBUG insights.client.utilities Core version: 3.0.110-1
2019-07-17 08:58:39,029    DEBUG insights.client.utilities All egg versions:
2019-07-17 08:58:39,029    DEBUG insights.client.utilities ENV egg not defined.
2019-07-17 08:58:39,029    DEBUG insights.client.utilities /var/lib/insights/newest.egg not found.
2019-07-17 08:58:39,800    DEBUG insights.client.utilities /var/lib/insights/last_stable.egg: 3.0.110-1
2019-07-17 08:58:40,096    DEBUG insights.client.utilities /etc/insights-client/rpm.egg: 3.0.4-2
2019-07-17 08:58:40,097    ERROR insights.client.phase.v1 Memory cgroup is disabled; insights-client will not run. To run anyway, set ignore_cgroup=True in /etc/insights-client/insights-client.conf
--------

This is a major regresssion with the past. You should not require to add a new cofniguration setting to get things working on a OS release where the client was working before for years.


See the offical RHEL6 documentation https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/6/html/resource_management_guide/ch-using_control_groups#The_cgconfig_Service that the cgroup is an optional that is not part of the Base OS installation.


Add OS detection for RHEL6 to implciltyl set ignore_cgroup=True so it works again out of the box


Please also provide an explanation Why Engineering and Testing did not found this issue as it is major Regression on a well known standard platform.




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run Egg 110 on standard RHEL6 without cgroups
2.
3.

Actual results:
Fail

Expected results:
Success


Additional info:

Comment 1 Jeff Needle 2019-07-17 11:58:18 UTC
My apologies, Peter.  This was a complete and total process breakdown on our part in our coordination, testing, and release gating processes.  We have reverted that change and a new egg will be available very soon (within the hour, it is propagating now).  We will be addressing the QE failure and make immediate changes.  This was inexcusable on our part.

Comment 2 Ian Page Hands 2019-07-17 12:19:25 UTC
Peter please accept another apology from myself. This was a fix that was meant to address an issue where certain customers were experiencing a client failure when cgroups was partially disabled. This was a P1 for those customers.

Obviously there was a bug and this affected a wider audience.

The new egg is going out now but I believe you will have to manually force an egg update. Or tweak the setting and then the egg will update. Unfortunately this check happens before the egg is updated on the machine I believe.

I think you do done of these:
- https://access.redhat.com/articles/3747741
- rm /var/lib/insights
- set ignore_cgroup=True in /etc/insights-client/insights-client.conf then run the client, then remove it

Comment 3 Peter Vreman 2019-07-18 13:20:31 UTC
Good to read that you have identified it as a missing part of the QE process.

I am not really affected by it as i have auto_update=False. I had only to revert my last commit, because i thought the egg was successful as the first run (in which the new egg is downloaded) was successful

Only then when looking for the output of a new feature to print the egg versions (based on a diff of the unpacked egg source code i found this feature was developed) i noticed it failed to start on RHEL6.10

Many Thanks for seeing the issue being picked up quickly.

Comment 4 Peter Vreman 2019-07-19 14:39:35 UTC
Confirmed egg 3.0.112 fixes the issue

Comment 8 errata-xmlrpc 2019-08-13 14:59:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2474


Note You need to log in before you can comment on or make changes to this bug.