Bug 1730648 - [RFE] Deduplication of hypervisor records by hostname to support RHEL-OSP / RHEV
Summary: [RFE] Deduplication of hypervisor records by hostname to support RHEL-OSP / RHEV
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Virt-who Configure Plugin
Version: 6.5.0
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: 6.6.0
Assignee: Marek Hulan
QA Contact: Kunxin Huang
satellite-doc-list
URL:
Whiteboard:
: 1755082 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-17 09:12 UTC by Ashish Humbe
Modified: 2019-11-20 15:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously, Satellite created duplicated profiles for RHEL-based hypervisors causing them to consume twice as many subscriptions. Users had to configure virt-who in VDSM mode manually on RHEL-based hypervisors prior to registering them to Satellite. From Satellite 6.6 onwards, Satellite creates unique profiles for RHEL-based hypervisors. Therefore, you must first register RHEL-based hypervisors with subscription-manager and then configure virt-who using the virt-who configuration tool in the Satellite web UI.
Clone Of:
Environment:
Last Closed: 2019-09-24 15:47:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2025503 None None None 2019-08-20 05:38:00 UTC

Description Ashish Humbe 2019-07-17 09:12:06 UTC
1. What is the nature and description of the request?  
-->
When configuring virt-who for RHEV or RHEL-OSP hypervisors/compute nodes, the proper configuration of virt-who is complex and complicated by the fact that the user may also register the hypervisor/compute nodes via subscription-manager. This effectively creates multiple consumer records within Candlepin making it difficult to properly attach subscriptions. 

 
2. Why does the customer need this? (List the business requirements here)  
-->
Most subscriptions that are sold for RHV/RHEL-OSP include content for 
both the hypervisor AND its guests. And since we cannot 'break' a 
subscriptions components across two host records, the customer ends up 
in a situation where they do not have enough subscriptions to properly 
subscribe both hypervisors.


3. How would the customer like to achieve this? (List the functional requirements here)  
--> There should be only one profile created for RHEV/RHEL OSP hypervisors through which Hypervisor can get updates and guests running on the hypervisor can inherit subscription.

Comment 3 William Poteat 2019-07-25 15:29:15 UTC
This issue has been remedied in candlepin in version 2.3.5+
The virt-who part was remedied in version 0.22.5+

Comment 4 William Poteat 2019-07-25 15:31:45 UTC
Related BZ's

1314902, 1410601, 1566000, 1576110

Comment 5 William Poteat 2019-07-25 15:31:56 UTC
Related BZ's

1314902, 1410601, 1566000, 1576110

Comment 7 Chris Snyder 2019-08-22 15:04:57 UTC
Virt-who supports the request from comment 6. Reassigning to the virt-who configure plugin for us to verify that plugin can generate a config capable of the same.

Comment 11 Eko 2019-09-24 08:59:54 UTC
According to our testing, this issue is already resolved in sat6.6, take vdsm host as the example, the actually result is:

if you create a rhevm virtwho-configure file for the vdsm mode, start virt-who service, you will see an entry with 'virt-who-xxx' in the webUI, and then if you run subscription-manager to register the vdsm host again, you will get error message:  "HTTP error (422 - Unknown): The DMI UUID of this hos..."

So the result is: Always only one entry displayed in the webUI for the same host.

Comment 13 Brad Buckingham 2019-09-24 15:47:08 UTC
Based upon comment 11, closing this bugzilla as 'nextrelease' as it will be resolved in Satellite 6.6.

Comment 14 Sergei Petrosian 2019-10-18 11:22:56 UTC
*** Bug 1755082 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.