Bug 173069 - hal-device-manager should be in Application->SystemTools menu
hal-device-manager should be in Application->SystemTools menu
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks: FC6Desktop
  Show dependency treegraph
 
Reported: 2005-11-13 10:48 EST by John Ellson
Modified: 2013-03-13 00:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-30 12:26:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-11-13 10:48:33 EST
Description of problem:
hal-device-manager should be in Application->SystemTools menu

I just found it yesterday myself and posted about it to fedora-test.  Willem
Riede responded in minutes with: "I didn't even know that existed - it is a
treasure trove of information!  I sure would like it more promently featured too."

Version-Release number of selected component (if applicable):
hal-gnome-0.5.4.cvs20051111-1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Willem Riede 2005-11-13 13:20:46 EST
I second this motion!
Comment 2 Michal Jaegermann 2005-11-13 15:28:17 EST
> I just found it yesterday myself 

Hm, ever wondered what 'hal-gnome' package is for?  What about 'lshal'?

> hal-device-manager should be in Application->SystemTools menu

Personally I am not so sure about it.  It is not really a tool - at least so
far.  It just lists in a graphical form some information which you can get
via 'lshal' as well, which is not that often in use, and really only root can
do something with that info.  Overloading menus is not such great idea.
Comment 3 John (J5) Palmieri 2005-11-13 16:30:11 EST
So that was the thinking on why it shouldn't go into the menus.  It really isn't
all that useful as a tool (we were going to make something much better but
haven't found the time).  However since a person needs to install the rpm
(nothing depends on it which is good), it might not be a bad idea to add it to
the menus.  We are in the mist of cleaning up the menus a bit so I will ask what
the other guys think.
Comment 4 Willem Riede 2005-11-14 22:13:47 EST
Well, I would certainly say that if a user cares enough to install it, (s)he
will appreciate it showing up in the menus. And while making a real tool out of
will be super, it is now already useful to see what hal is up to. Much more
accessable / user friendly than lshal. I would also like to see more attention
to tools like these in the release notes, as now these new capabilities go
unnoticed.
Comment 5 Rahul Sundaram 2006-08-29 15:20:27 EDT

This seems to be installed by default and doesnt show up on the menus though
which is rather strange to me. Can we make this show up on the menu before FC6?
Comment 6 Matthias Clasen 2006-08-29 15:56:11 EDT
I'd say

a) put it in the menus if installed
b) don't install it by default
Comment 7 Rahul Sundaram 2006-08-29 16:00:38 EDT

I think this is a quite a small and useful utility to have it installed by
default. Pretty much every mainstream distribution afaik. 
Comment 8 Matthias Clasen 2006-08-29 16:38:54 EDT
It may have some value for a certain group of users, yes.
But useful enough for a large enough group of users to justify
cluttering the default menus ? In my opinion, no.
Comment 9 Rahul Sundaram 2006-08-30 07:27:43 EDT
We have been including hwbrowser in previous releases for a long time and a
graphical view of the hardware available is very basic information that needs to
be provided by default.  Is there a reason it is called hal-gnome? seems to use
only gtk. 

My suggestions would be 

* Drop hwbrowser from Fedora Core. It can be moved to Fedora Extras if there is
still interest in maintaining it.

* Install and provide a menu entry by default for hal-gnome 
Comment 10 Matthias Clasen 2006-08-30 10:36:44 EDT
hwbrowser is a lot more reasonable, ui-wise, compared to hal-device-manager.
Comment 11 Matthias Clasen 2006-08-30 12:26:23 EDT
I went with the general consensus in the desktop team, which is to add a desktop
file, and make the package optional. Longer-term, it would be good to transplant
the hwbrowser ui on top of hal-device-manager to arrive at something that could
form the basis for a more usable and useful tool.

Note You need to log in before you can comment on or make changes to this bug.