Bug 1730698 - Canon CanoScan Lide 300 scanner detected but driver does not work
Summary: Canon CanoScan Lide 300 scanner detected but driver does not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sane-backends
Version: 30
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-17 11:52 UTC by Dipankar Das
Modified: 2019-07-31 01:04 UTC (History)
4 users (show)

Fixed In Version: sane-backends-1.0.27-24.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-31 01:04:40 UTC


Attachments (Terms of Use)
file debug.log. (230.50 KB, text/plain)
2019-07-17 15:35 UTC, Dipankar Das
no flags Details

Description Dipankar Das 2019-07-17 11:52:02 UTC
Description of problem:
After I connected the new scanner to the USB port and ran 'xsane', it
showed 'no devices available'. But if I run 'lsusb' it is getting this
canon device:

Bus 001 Device 005: ID 04a9:12fe Canon, Inc

I downloaded the driver from this link:
http://pdisp01.c-wss.com/gdl/WWUFORedirectTarget.do?id=MDEwMDAwOTkzMjAx&cmp=ABR&lang=EN

And the driver scangearmp2-3.70-1.x86_64.rpm was installed.

But still 'xsane' is not finding it but 'lsusb' is showing it.
'sane-find-scanner' is getting it.

<<
[dd@mamdo docs]$ sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9 [Canon], product=0x1913 [LiDE 300])
at libusb:002:005
could not open USB device 0x8087/0x0024 at 002:002: Access denied
(insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 002:001: Access denied
(insufficient permissions)
could not open USB device 0x8087/0x0024 at 001:002: Access denied
(insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 001:001: Access denied
(insufficient permissions)
could not open USB device 0x1d6b/0x0003 at 004:001: Access denied
(insufficient permissions)
could not open USB device 0x046d/0xc077 at 003:003: Access denied
(insufficient permissions)
could not open USB device 0x04d9/0x1203 at 003:002: Access denied
(insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 003:001: Access denied
(insufficient permissions)
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.
>>

But, 'scanimage -L' is not giving any result.

<<
[dd@mamdo docs]$ scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

>>


Version-Release number of selected component (if applicable): Fedora 30


How reproducible: Running 'xsane'


Steps to Reproduce:
1.'sane-findscanner' is detecting the scanner
2.'scanimage -L' is not giving any result
3.'xsane' is finding no device

Comment 1 Zdenek Dohnal 2019-07-17 12:36:31 UTC
Hi Dipankar,

thank you for reporting the issue! Would you mind telling me if it is regression (scanner worked in the past)? Would you mind attaching a file with logs called debug.log gathered by following command:

$ SANE_DEBUG_DLL=255 SANE_DEBUG_SANEI_USB=255 scanimage -L &> debug.log

Comment 2 Dipankar Das 2019-07-17 13:32:54 UTC
(In reply to Zdenek Dohnal from comment #1)
> Hi Dipankar,
> 
> thank you for reporting the issue! Would you mind telling me if it is
> regression (scanner worked in the past)? Would you mind attaching a file
> with logs called debug.log gathered by following command:
> 
> $ SANE_DEBUG_DLL=255 SANE_DEBUG_SANEI_USB=255 scanimage -L &> debug.log

Dear Zdenek 

What I have got to do with this command? Please tell me, I don't know anything here. 

Thank you anyway.

Comment 3 Zdenek Dohnal 2019-07-17 14:37:56 UTC
(In reply to Dipankar Das from comment #2)
> (In reply to Zdenek Dohnal from comment #1)
> > Hi Dipankar,
> > 
> > thank you for reporting the issue! Would you mind telling me if it is
> > regression (scanner worked in the past)?

Would you mind answering the question? It can help me understand if it is regression against old versions of sane-backends or the support is missing completely.

>> Would you mind attaching a file
> > with logs called debug.log gathered by following command:
> > 
> > $ SANE_DEBUG_DLL=255 SANE_DEBUG_SANEI_USB=255 scanimage -L &> debug.log
> 
> Dear Zdenek 
> 
> What I have got to do with this command? Please tell me, I don't know
> anything here. 

Please use it in your terminal, it will create file called 'debug.log' which please attach to this bugzilla. Thank you in advance!

> 
> Thank you anyway.

Comment 4 Dipankar Das 2019-07-17 15:35:36 UTC
Created attachment 1591467 [details]
file debug.log.

Comment 5 Zdenek Dohnal 2019-07-18 10:57:12 UTC
Actually, CanoScan LiDE 300 is not supported by stable sane-backends yet, but I backported the patch for adding its support. 

Would you mind testing if it works? 

There is a scratch build https://koji.fedoraproject.org/koji/taskinfo?taskID=36319980 where:

1) click on your desired architecture
2) you will see links to rpms
3) copy the links
4) issue command with acquired links:

$ sudo dnf -y install <link1> ... <linkN>

Comment 6 Zdenek Dohnal 2019-07-18 10:59:02 UTC
Please wait a bit, I'll supply successful build.

Comment 7 Zdenek Dohnal 2019-07-18 11:18:05 UTC
Successful build: https://koji.fedoraproject.org/koji/taskinfo?taskID=36320429

Comment 8 Dipankar Das 2019-07-18 14:36:50 UTC
(In reply to Zdenek Dohnal from comment #7)
> Successful build:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=36320429

Pasting here the whole output:

[dd@mamdo ~]$ su -
Password: 
[root@mamdo ~]# dnf install /home/dd/sane-backends-1.0.27-24.fc30.x86_64.rpm 
Last metadata expiration check: 0:15:06 ago on Thu 18 Jul 2019 07:15:09 PM IST.
Error: 
 Problem: conflicting requests
  - nothing provides sane-backends-libs(x86-64) = 1.0.27-24.fc30 needed by sane-backends-1.0.27-24.fc30.x86_64
(try to add '--skip-broken' to skip uninstallable packages)
[root@mamdo ~]# dnf --skip-broken install /home/dd/sane-backends-1.0.27-24.fc30.x86_64.rpm 
Last metadata expiration check: 0:15:55 ago on Thu 18 Jul 2019 07:15:09 PM IST.
Dependencies resolved.

 Problem: conflicting requests
  - nothing provides sane-backends-libs(x86-64) = 1.0.27-24.fc30 needed by sane-backends-1.0.27-24.fc30.x86_64
==============================================================================================================================================================================================
 Package                                        Architecture                            Version                                           Repository                                     Size
==============================================================================================================================================================================================
Skipping packages with broken dependencies:
 sane-backends                                  x86_64                                  1.0.27-24.fc30                                    @commandline                                  763 k

Transaction Summary
==============================================================================================================================================================================================
Skip  1 Package

Nothing to do.
Complete!
============================================================================================

After the installation done I tried to get the result of 'sane-find-scanner' and 'scanimage -L':

[dd@mamdo ~]$ sane-find-scanner 

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9 [Canon], product=0x1913 [LiDE 300]) at libusb:002:003
could not open USB device 0x8087/0x0024 at 002:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 002:001: Access denied (insufficient permissions)
could not open USB device 0x8087/0x0024 at 001:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 001:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0003 at 004:001: Access denied (insufficient permissions)
could not open USB device 0x046d/0xc077 at 003:003: Access denied (insufficient permissions)
could not open USB device 0x04d9/0x1203 at 003:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 003:001: Access denied (insufficient permissions)
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.
[dd@mamdo ~]$ scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Comment 9 Dipankar Das 2019-07-18 14:42:01 UTC
'xsane' coule not find the device even after this installation.

Comment 11 Dipankar Das 2019-07-18 16:17:49 UTC
This is whole thing that happened on the command-line, logged-in as root:

[root@mamdo ~]# dnf -y install https://kojipkgs.fedoraproject.org//work/tasks/432/36320432/sane-backends-1.0.27-24.fc30.x86_64.rpm https://kojipkgs.fedoraproject.org//work/tasks/432/36320432/sane-backends-drivers-cameras-1.0.27-24.fc30.x86_64.rpm https://kojipkgs.fedoraproject.org//work/tasks/432/36320432/sane-backends-drivers-scanners-1.0.27-24.fc30.x86_64.rpm https://kojipkgs.fedoraproject.org//work/tasks/432/36320432/sane-backends-libs-1.0.27-24.fc30.x86_64.rpm
Last metadata expiration check: 0:16:20 ago on Thu 18 Jul 2019 09:21:26 PM IST.
sane-backends-1.0.27-24.fc30.x86_64.rpm                                                                                                                       201 kB/s | 763 kB     00:03    
sane-backends-drivers-cameras-1.0.27-24.fc30.x86_64.rpm                                                                                                        14 kB/s |  29 kB     00:02    
sane-backends-drivers-scanners-1.0.27-24.fc30.x86_64.rpm                                                                                                      511 kB/s | 2.3 MB     00:04    
sane-backends-libs-1.0.27-24.fc30.x86_64.rpm                                                                                                                   33 kB/s |  79 kB     00:02    
Error: 
 Problem 1: problem with installed package sane-backends-drivers-scanners-1.0.27-23.fc30.i686
  - package sane-backends-drivers-scanners-1.0.27-23.fc30.i686 requires sane-backends = 1.0.27-23.fc30, but none of the providers can be installed
  - cannot install both sane-backends-1.0.27-24.fc30.x86_64 and sane-backends-1.0.27-23.fc30.x86_64
  - conflicting requests
 Problem 2: problem with installed package sane-backends-drivers-cameras-1.0.27-23.fc30.i686
  - sane-backends-drivers-cameras-1.0.27-23.fc30.i686 has inferior architecture
  - cannot install both sane-backends-drivers-cameras-1.0.27-24.fc30.x86_64 and sane-backends-drivers-cameras-1.0.27-23.fc30.x86_64
  - conflicting requests
 Problem 3: problem with installed package sane-backends-daemon-1.0.27-23.fc30.x86_64
  - package sane-backends-daemon-1.0.27-23.fc30.x86_64 requires sane-backends-libs(x86-64) = 1.0.27-23.fc30, but none of the providers can be installed
  - cannot install both sane-backends-libs-1.0.27-24.fc30.x86_64 and sane-backends-libs-1.0.27-23.fc30.x86_64
  - conflicting requests
 Problem 4: problem with installed package sane-backends-libs-1.0.27-23.fc30.i686
  - sane-backends-libs-1.0.27-23.fc30.i686 has inferior architecture
  - cannot install both sane-backends-libs-1.0.27-24.fc30.x86_64 and sane-backends-libs-1.0.27-23.fc30.x86_64
  - package sane-backends-drivers-scanners-1.0.27-24.fc30.x86_64 requires sane-backends-libs(x86-64) = 1.0.27-24.fc30, but none of the providers can be installed
  - conflicting requests
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)
[root@mamdo ~]# dnf --skip-broken --allowerasing -y install https://kojipkgs.fedoraproject.org//work/tasks/432/36320432/sane-backends-1.0.27-24.fc30.x86_64.rpm https://kojipkgs.fedoraproject.org//work/tasks/432/36320432/sane-backends-drivers-cameras-1.0.27-24.fc30.x86_64.rpm https://kojipkgs.fedoraproject.org//work/tasks/432/36320432/sane-backends-drivers-scanners-1.0.27-24.fc30.x86_64.rpm https://kojipkgs.fedoraproject.org//work/tasks/432/36320432/sane-backends-libs-1.0.27-24.fc30.x86_64.rpm
Last metadata expiration check: 0:17:42 ago on Thu 18 Jul 2019 09:21:26 PM IST.
sane-backends-1.0.27-24.fc30.x86_64.rpm                                                                                                                       216 kB/s | 763 kB     00:03    
sane-backends-drivers-cameras-1.0.27-24.fc30.x86_64.rpm                                                                                                        18 kB/s |  29 kB     00:01    
sane-backends-drivers-scanners-1.0.27-24.fc30.x86_64.rpm                                                                                                      458 kB/s | 2.3 MB     00:05    
sane-backends-libs-1.0.27-24.fc30.x86_64.rpm                                                                                                                   41 kB/s |  79 kB     00:01    
Dependencies resolved.
Nothing to do.
Complete!
[root@mamdo ~]# 

After this installation was complete I logged out from 'root' and as a normal user:

[dd@mamdo ~]$ sane-find-scanner 

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9 [Canon], product=0x1913 [LiDE 300]) at libusb:002:003
could not open USB device 0x8087/0x0024 at 002:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 002:001: Access denied (insufficient permissions)
could not open USB device 0x8087/0x0024 at 001:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 001:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0003 at 004:001: Access denied (insufficient permissions)
could not open USB device 0x046d/0xc077 at 003:003: Access denied (insufficient permissions)
could not open USB device 0x04d9/0x1203 at 003:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 003:001: Access denied (insufficient permissions)
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.
[dd@mamdo ~]$ scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[dd@mamdo ~]$ xsane
This time too 'xsane' could not find the device

Comment 13 Dipankar Das 2019-07-19 10:58:34 UTC
(In reply to Zdenek Dohnal from comment #12)
> You have i686 arch, but you chose x86_64 arch in
> https://bugzilla.redhat.com/show_bug.cgi?id=1730698#c8 ... so I thought you
> know your arch and supplied you links for x86 rpms...
> 
> Please issue this command:
> 
> dnf -y install
> https://kojipkgs.fedoraproject.org//work/tasks/431/36320431/sane-backends-1.
> 0.27-24.fc30.i686.rpm
> https://kojipkgs.fedoraproject.org//work/tasks/431/36320431/sane-backends-
> drivers-cameras-1.0.27-24.fc30.i686.rpm
> https://kojipkgs.fedoraproject.org//work/tasks/431/36320431/sane-backends-
> drivers-scanners-1.0.27-24.fc30.i686.rpm
> https://kojipkgs.fedoraproject.org//work/tasks/431/36320431/sane-backends-
> libs-1.0.27-24.fc30.i686.rpm
> https://kojipkgs.fedoraproject.org//work/tasks/431/36320431/sane-backends-
> daemon-1.0.27-24.fc30.i686.rpm

Dear Friend Dohnal

I do not know these differences -- but for almost a decade now I am using 64-bit version of Fedora. Are you sure it is i686? And if that is, should I go on using 64bit version?

Installing those packages the way you wanted created this result. I am pasting the whole thing here:

dnf -y install https://kojipkgs.fedoraproject.org//work/tasks/431/36320431/sane-backends-1.0.27-24.fc30.i686.rpm https://kojipkgs.fedoraproject.org//work/tasks/431/36320431/sane-backends-drivers-cameras-1.0.27-24.fc30.i686.rpm https://kojipkgs.fedoraproject.org//work/tasks/431/36320431/sane-backends-drivers-scanners-1.0.27-24.fc30.i686.rpm https://kojipkgs.fedoraproject.org//work/tasks/431/36320431/sane-backends-libs-1.0.27-24.fc30.i686.rpm https://kojipkgs.fedoraproject.org//work/tasks/431/36320431/sane-backends-daemon-1.0.27-24.fc30.i686.rpm
Last metadata expiration check: 0:03:12 ago on Fri 19 Jul 2019 04:22:28 PM IST.
sane-backends-1.0.27-24.fc30.i686.rpm                                                                                                                         239 kB/s | 765 kB     00:03    
sane-backends-drivers-cameras-1.0.27-24.fc30.i686.rpm                                                                                                          15 kB/s |  31 kB     00:02    
sane-backends-drivers-scanners-1.0.27-24.fc30.i686.rpm                                                                                                        485 kB/s | 2.4 MB     00:05    
sane-backends-libs-1.0.27-24.fc30.i686.rpm                                                                                                                     34 kB/s |  85 kB     00:02    
sane-backends-daemon-1.0.27-24.fc30.i686.rpm                                                                                                                   17 kB/s |  34 kB     00:01    
Dependencies resolved.
==============================================================================================================================================================================================
 Package                                                     Architecture                      Version                                        Repository                                 Size
==============================================================================================================================================================================================
Installing:
 sane-backends                                               i686                              1.0.27-24.fc30                                 @commandline                              765 k
 sane-backends-daemon                                        i686                              1.0.27-24.fc30                                 @commandline                               34 k
Upgrading:
 sane-backends-drivers-cameras                               i686                              1.0.27-24.fc30                                 @commandline                               31 k
 sane-backends-drivers-scanners                              i686                              1.0.27-24.fc30                                 @commandline                              2.4 M
 sane-backends-libs                                          i686                              1.0.27-24.fc30                                 @commandline                               85 k

Transaction Summary
==============================================================================================================================================================================================
Install  2 Packages
Upgrade  3 Packages

Total size: 3.3 M
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Error: Transaction check error:
  file /usr/lib/udev/hwdb.d/20-sane-backends.hwdb from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/lib/udev/rules.d/65-sane-backends.rules from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-abaton.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-apple.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-artec.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-avision.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-bh.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-canon.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-canon630u.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-canon_pp.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-coolscan.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-coolscan2.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-coolscan3.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-dc210.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-dc240.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-dc25.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-dll.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-dmc.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-epson.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-epson2.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-epsonds.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-genesys.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-gphoto2.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-gt68xx.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-hp.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-hp3500.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-hp3900.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-hp4200.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-hp5400.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-hp5590.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-hpljm1005.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-hpsj5s.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-hs2p.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-ibm.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-leo.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-lexmark.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-ma1509.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-magicolor.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-matsushita.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-microtek.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-microtek2.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-mustek.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-mustek_pp.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-mustek_usb.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-mustek_usb2.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-nec.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-net.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-niash.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-p5.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-pie.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-pieusb.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-pixma.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-plustek.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-plustek_pp.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-qcam.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-ricoh.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-rts8891.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-s9036.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-sceptre.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-sharp.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-sm3600.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-sm3840.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-snapscan.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-st400.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-stv680.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-tamarack.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-teco1.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-teco2.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-teco3.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-test.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-u12.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-umax.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-umax1220u.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-umax_pp.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-v4l.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man5/sane-xerox_mfp.5.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64
  file /usr/share/man/man7/sane.7.gz from install of sane-backends-1.0.27-24.fc30.i686 conflicts with file from package sane-backends-1.0.27-23.fc30.x86_64

Error Summary
-------------

Is there any way to be sure my machine is i686 or x86_64?

Comment 14 Dipankar Das 2019-07-19 11:09:43 UTC
I used three commands to determine the architecture of my machine. Reproducing here all the three results:

[dd@mamdo ~]$ uname -m
x86_64
[dd@mamdo ~]$ uname -a
Linux mamdo.ddnet 5.1.17-300.fc30.x86_64 #1 SMP Wed Jul 10 15:20:27 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
[dd@mamdo ~]$ lscpu
Architecture:        x86_64
CPU op-mode(s):      32-bit, 64-bit
Byte Order:          Little Endian
Address sizes:       36 bits physical, 48 bits virtual
CPU(s):              4
On-line CPU(s) list: 0-3
Thread(s) per core:  1
Core(s) per socket:  4
Socket(s):           1
NUMA node(s):        1
Vendor ID:           GenuineIntel
CPU family:          6
Model:               58
Model name:          Intel(R) Core(TM) i5-3450 CPU @ 3.10GHz
Stepping:            9
CPU MHz:             1596.368
CPU max MHz:         3500.0000
CPU min MHz:         1600.0000
BogoMIPS:            6185.87
Virtualization:      VT-x
L1d cache:           32K
L1i cache:           32K
L2 cache:            256K
L3 cache:            6144K
NUMA node0 CPU(s):   0-3
Flags:               fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm cpuid_fault epb pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms xsaveopt dtherm ida arat pln pts md_clear flush_l1d
[dd@mamdo ~]$ 

As these criteria are indicating, as I know from the Net, it seems my machine is x86_64, IMHO.

Comment 15 Zdenek Dohnal 2019-07-19 11:34:20 UTC
Hmm... your machine is x86_64, but you have sane-backends packages installed as i686.

Please issue those commands:

$ sudo dnf remove sane-backends sane-backends-libs sane-backends-drivers-cameras sane-backends-drivers-scanners

$ sudo dnf -y install https://kojipkgs.fedoraproject.org//work/tasks/432/36320432/sane-backends-1.0.27-24.fc30.x86_64.rpm https://kojipkgs.fedoraproject.org//work/tasks/432/36320432/sane-backends-drivers-cameras-1.0.27-24.fc30.x86_64.rpm https://kojipkgs.fedoraproject.org//work/tasks/432/36320432/sane-backends-drivers-scanners-1.0.27-24.fc30.x86_64.rpm https://kojipkgs.fedoraproject.org//work/tasks/432/36320432/sane-backends-libs-1.0.27-24.fc30.x86_64.rpm

Thank you!

Comment 16 Dipankar Das 2019-07-19 12:26:29 UTC
A lot of thanks Dear Dohnal -- finally it worked.

Comment 17 Dipankar Das 2019-07-19 12:34:49 UTC
Dear Dohnal it is not working once again. I reinstalled some of the packages like wine xsane xsane-gimp and after that xsane is not working once again. Last time after sane-find-scanner did get it, 'scanimage -L' was showing the proper details and after that 'xsane' worked. Now nothing other than 'sane-find-scanner' is working. 

I am now going to do once again the steps that you told me before it worked.

Comment 18 Dipankar Das 2019-07-19 12:47:12 UTC
I went through your steps in Comment 15. 

Then I ran these three:

sane-find-scanner
scanimage -L
xsane

'xsane' I had to install. Now it is working fine.

But -- which packages I should NOT install once again?

Comment 19 Fedora Update System 2019-07-19 13:06:35 UTC
FEDORA-2019-62a7424aaf has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-62a7424aaf

Comment 20 Fedora Update System 2019-07-20 01:00:06 UTC
sane-backends-1.0.27-24.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-62a7424aaf

Comment 21 Dipankar Das 2019-07-30 07:30:06 UTC
Today when I tried to work with the scanner, it did not. Again that 'device not found' on xsan. Once again I had to go through the steps of Comment 15. 

The first step was: sudo dnf remove sane-backends sane-backends-libs sane-backends-drivers-cameras sane-backends-drivers-scanners

This action generated this list of packages removed:

Removed:
  sane-backends-1.0.27-23.fc30.x86_64                             sane-backends-drivers-cameras-1.0.27-23.fc30.x86_64            sane-backends-drivers-cameras-1.0.27-23.fc30.i686           
  sane-backends-drivers-scanners-1.0.27-23.fc30.x86_64            sane-backends-drivers-scanners-1.0.27-23.fc30.i686             sane-backends-libs-1.0.27-23.fc30.x86_64                    
  sane-backends-libs-1.0.27-23.fc30.i686                          wine-4.12.1-1.fc30.x86_64                                      xsane-0.999-33.fc30.x86_64                                  
  gd-2.2.5-8.fc30.i686                                            isdn4k-utils-3.27-17.fc30.x86_64                               isdn4k-utils-3.27-17.fc30.i686                              
  isdn4k-utils-data-3.27-17.fc30.noarch                           libXpm-3.5.12-9.fc30.i686                                      libexif-0.6.21-19.fc30.i686                                 
  libgphoto2-2.5.21-3.fc30.i686                                   libieee1284-0.2.11-30.fc30.x86_64                              libieee1284-0.2.11-30.fc30.i686                             
  libtool-ltdl-2.4.6-29.fc30.i686                                 libv4l-1.16.5-3.fc30.i686                                      libva-2.4.1-1.fc30.i686                                     
  libvkd3d-1.1-2.fc30.x86_64                                      libvkd3d-1.1-2.fc30.i686                                       libwebp-1.0.2-2.fc30.i686                                   
  mesa-libOSMesa-19.0.8-1.fc30.x86_64                             mesa-libOSMesa-19.0.8-1.fc30.i686                              mesa-vulkan-drivers-19.0.8-1.fc30.i686                      
  mingw32-wine-gecko-2.47-2.fc26.noarch                           mingw64-wine-gecko-2.47-2.fc26.noarch                          mpg123-libs-1.25.10-2.fc30.i686                             
  samba-common-tools-2:4.10.5-1.fc30.x86_64                       samba-winbind-2:4.10.5-1.fc30.x86_64                           samba-winbind-clients-2:4.10.5-1.fc30.x86_64                
  samba-winbind-modules-2:4.10.5-1.fc30.x86_64                    spirv-tools-libs-2019.1-1.fc30.i686                            unixODBC-2.3.7-4.fc30.x86_64                                
  unixODBC-2.3.7-4.fc30.i686                                      vulkan-loader-1.1.97.0-0.fc30.i686                             wine-alsa-4.12.1-1.fc30.x86_64                              
  wine-alsa-4.12.1-1.fc30.i686                                    wine-arial-fonts-4.12.1-1.fc30.noarch                          wine-capi-4.12.1-1.fc30.x86_64                              
  wine-capi-4.12.1-1.fc30.i686                                    wine-cms-4.12.1-1.fc30.x86_64                                  wine-cms-4.12.1-1.fc30.i686                                 
  wine-common-4.12.1-1.fc30.noarch                                wine-core-4.12.1-1.fc30.x86_64                                 wine-core-4.12.1-1.fc30.i686                                
  wine-courier-fonts-4.12.1-1.fc30.noarch                         wine-desktop-4.12.1-1.fc30.noarch                              wine-filesystem-4.12.1-1.fc30.noarch                        
  wine-fixedsys-fonts-4.12.1-1.fc30.noarch                        wine-fonts-4.12.1-1.fc30.noarch                                wine-ldap-4.12.1-1.fc30.x86_64                              
  wine-ldap-4.12.1-1.fc30.i686                                    wine-marlett-fonts-4.12.1-1.fc30.noarch                        wine-mono-4.9.0-1.fc30.noarch                               
  wine-ms-sans-serif-fonts-4.12.1-1.fc30.noarch                   wine-openal-4.12.1-1.fc30.x86_64                               wine-openal-4.12.1-1.fc30.i686                              
  wine-opencl-4.12.1-1.fc30.x86_64                                wine-opencl-4.12.1-1.fc30.i686                                 wine-pulseaudio-4.12.1-1.fc30.x86_64                        
  wine-pulseaudio-4.12.1-1.fc30.i686                              wine-small-fonts-4.12.1-1.fc30.noarch                          wine-symbol-fonts-4.12.1-1.fc30.noarch                      
  wine-system-fonts-4.12.1-1.fc30.noarch                          wine-systemd-4.12.1-1.fc30.noarch                              wine-tahoma-fonts-4.12.1-1.fc30.noarch                      
  wine-times-new-roman-fonts-4.12.1-1.fc30.noarch                 wine-twain-4.12.1-1.fc30.x86_64                                wine-twain-4.12.1-1.fc30.i686                               
  wine-wingdings-fonts-4.12.1-1.fc30.noarch                      

Then sane-find-scanner and scanimage -L worked fine. I had to install xsane and I did my scan. 

But what pushed the scanner from working to non-working. As we can see in the list, it gives a lot of wine packages. And recently I had to re-install wine after the earlier time I had to remove all those listed packages. 

I think it is wine that is doing this.

Comment 22 Dipankar Das 2019-07-30 07:38:53 UTC
To test my hypothesis I did sudo dnf install wine and for dependency the system installed all these:

Dependencies resolved.
==============================================================================================================================================================================================
 Package                                                      Architecture                         Version                                        Repository                             Size
==============================================================================================================================================================================================
Installing:
 wine                                                         x86_64                               4.12.1-1.fc30                                  updates                                12 k
Upgrading:
 libsmbclient                                                 x86_64                               2:4.10.6-0.fc30                                updates                                71 k
 libwbclient                                                  x86_64                               2:4.10.6-0.fc30                                updates                                44 k
 mesa-libGL                                                   i686                                 19.1.3-1.fc30                                  updates                               161 k
 mesa-libGL                                                   x86_64                               19.1.3-1.fc30                                  updates                               150 k
 mesa-libglapi                                                i686                                 19.1.3-1.fc30                                  updates                                36 k
 mesa-libglapi                                                x86_64                               19.1.3-1.fc30                                  updates                                36 k
 mesa-vulkan-drivers                                          x86_64                               19.1.3-1.fc30                                  updates                               2.5 M
 samba-client                                                 x86_64                               2:4.10.6-0.fc30                                updates                               547 k
 samba-client-libs                                            x86_64                               2:4.10.6-0.fc30                                updates                               4.8 M
 samba-common                                                 noarch                               2:4.10.6-0.fc30                                updates                               142 k
 samba-common-libs                                            x86_64                               2:4.10.6-0.fc30                                updates                                98 k
 samba-libs                                                   x86_64                               2:4.10.6-0.fc30                                updates                               103 k
Installing dependencies:
 libv4l                                                       i686                                 1.16.5-3.fc30                                  updates                               183 k
 mesa-libOSMesa                                               i686                                 19.1.3-1.fc30                                  updates                               2.7 M
 mesa-libOSMesa                                               x86_64                               19.1.3-1.fc30                                  updates                               2.5 M
 mesa-vulkan-drivers                                          i686                                 19.1.3-1.fc30                                  updates                               2.7 M
 samba-common-tools                                           x86_64                               2:4.10.6-0.fc30                                updates                               381 k
 samba-winbind                                                x86_64                               2:4.10.6-0.fc30                                updates                               469 k
 samba-winbind-clients                                        x86_64                               2:4.10.6-0.fc30                                updates                                73 k
 samba-winbind-modules                                        x86_64                               2:4.10.6-0.fc30                                updates                                51 k
 wine-alsa                                                    i686                                 4.12.1-1.fc30                                  updates                                70 k
 wine-alsa                                                    x86_64                               4.12.1-1.fc30                                  updates                                74 k
 wine-arial-fonts                                             noarch                               4.12.1-1.fc30                                  updates                                99 k
 wine-capi                                                    i686                                 4.12.1-1.fc30                                  updates                                17 k
 wine-capi                                                    x86_64                               4.12.1-1.fc30                                  updates                                17 k
 wine-cms                                                     i686                                 4.12.1-1.fc30                                  updates                                40 k
 wine-cms                                                     x86_64                               4.12.1-1.fc30                                  updates                                44 k
 wine-common                                                  noarch                               4.12.1-1.fc30                                  updates                                65 k
 wine-core                                                    i686                                 4.12.1-1.fc30                                  updates                                84 M
 wine-core                                                    x86_64                               4.12.1-1.fc30                                  updates                                88 M
 wine-courier-fonts                                           noarch                               4.12.1-1.fc30                                  updates                                89 k
 wine-desktop                                                 noarch                               4.12.1-1.fc30                                  updates                               113 k
 wine-filesystem                                              noarch                               4.12.1-1.fc30                                  updates                                46 k
 wine-fixedsys-fonts                                          noarch                               4.12.1-1.fc30                                  updates                                24 k
 wine-fonts                                                   noarch                               4.12.1-1.fc30                                  updates                                11 k
 wine-ldap                                                    i686                                 4.12.1-1.fc30                                  updates                                86 k
 wine-ldap                                                    x86_64                               4.12.1-1.fc30                                  updates                                92 k
 wine-marlett-fonts                                           noarch                               4.12.1-1.fc30                                  updates                                23 k
 wine-mono                                                    noarch                               4.9.0-1.fc30                                   updates                                64 M
 wine-ms-sans-serif-fonts                                     noarch                               4.12.1-1.fc30                                  updates                               1.6 M
 wine-openal                                                  i686                                 4.12.1-1.fc30                                  updates                                21 k
 wine-openal                                                  x86_64                               4.12.1-1.fc30                                  updates                                24 k
 wine-opencl                                                  i686                                 4.12.1-1.fc30                                  updates                                27 k
 wine-opencl                                                  x86_64                               4.12.1-1.fc30                                  updates                                29 k
 wine-pulseaudio                                              i686                                 4.12.1-1.fc30                                  updates                                61 k
 wine-pulseaudio                                              x86_64                               4.12.1-1.fc30                                  updates                                64 k
 wine-small-fonts                                             noarch                               4.12.1-1.fc30                                  updates                                26 k
 wine-symbol-fonts                                            noarch                               4.12.1-1.fc30                                  updates                                37 k
 wine-system-fonts                                            noarch                               4.12.1-1.fc30                                  updates                                30 k
 wine-systemd                                                 noarch                               4.12.1-1.fc30                                  updates                                12 k
 wine-tahoma-fonts                                            noarch                               4.12.1-1.fc30                                  updates                               115 k
 wine-times-new-roman-fonts                                   noarch                               4.12.1-1.fc30                                  updates                               105 k
 wine-twain                                                   i686                                 4.12.1-1.fc30                                  updates                                93 k
 wine-twain                                                   x86_64                               4.12.1-1.fc30                                  updates                               100 k
 wine-wingdings-fonts                                         noarch                               4.12.1-1.fc30                                  updates                                24 k
 gd                                                           i686                                 2.2.5-8.fc30                                   fedora                                135 k
 isdn4k-utils                                                 i686                                 3.27-17.fc30                                   fedora                                1.1 M
 isdn4k-utils                                                 x86_64                               3.27-17.fc30                                   fedora                                1.1 M
 isdn4k-utils-data                                            noarch                               3.27-17.fc30                                   fedora                                323 k
 libXpm                                                       i686                                 3.5.12-9.fc30                                  fedora                                 56 k
 libexif                                                      i686                                 0.6.21-19.fc30                                 fedora                                346 k
 libgphoto2                                                   i686                                 2.5.21-3.fc30                                  fedora                                1.4 M
 libieee1284                                                  i686                                 0.2.11-30.fc30                                 fedora                                 41 k
 libtool-ltdl                                                 i686                                 2.4.6-29.fc30                                  fedora                                 36 k
 libva                                                        i686                                 2.4.1-1.fc30                                   fedora                                 86 k
 libvkd3d                                                     i686                                 1.1-2.fc30                                     fedora                                157 k
 libvkd3d                                                     x86_64                               1.1-2.fc30                                     fedora                                150 k
 libwebp                                                      i686                                 1.0.2-2.fc30                                   fedora                                274 k
 mingw32-wine-gecko                                           noarch                               2.47-2.fc26                                    fedora                                 48 M
 mingw64-wine-gecko                                           noarch                               2.47-2.fc26                                    fedora                                 49 M
 mpg123-libs                                                  i686                                 1.25.10-2.fc30                                 fedora                                212 k
 sane-backends-libs                                           i686                                 1.0.27-23.fc30                                 fedora                                 85 k
 spirv-tools-libs                                             i686                                 2019.1-1.fc30                                  fedora                                1.2 M
 unixODBC                                                     i686                                 2.3.7-4.fc30                                   fedora                                428 k
 unixODBC                                                     x86_64                               2.3.7-4.fc30                                   fedora                                411 k
 vulkan-loader                                                i686                                 1.1.97.0-0.fc30                                fedora                                109 k
Installing weak dependencies:
 sane-backends-drivers-cameras                                i686                                 1.0.27-23.fc30                                 fedora                                 31 k
 sane-backends-drivers-scanners                               i686                                 1.0.27-23.fc30                                 fedora                                2.4 M
Downgrading:
 sane-backends                                                x86_64                               1.0.27-23.fc30                                 fedora                                763 k
 sane-backends-drivers-cameras                                x86_64                               1.0.27-23.fc30                                 fedora                                 29 k
 sane-backends-drivers-scanners                               x86_64                               1.0.27-23.fc30                                 fedora                                2.3 M
 sane-backends-libs                                           x86_64                               1.0.27-23.fc30                                 fedora                                 79 k

-----------------------------------------------

The last five lines, I think are doing the things: 'downgrading'. 
This time I did not hit y and my scanner is still working. But no wine. 

What to do now? I am using my Bookshelf SW from 1998, I am quite dependent on it. And it needs wine to run. How I can use it together with my scanner?

Comment 23 Zdenek Dohnal 2019-07-30 08:03:50 UTC
Wait until new sane-backends update will get into stable repos or enable testing repo when installing sane-backends for now.

Comment 24 Fedora Update System 2019-07-31 01:04:40 UTC
sane-backends-1.0.27-24.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.