Bug 173074 - Loader stalls when doing telnet installation
Loader stalls when doing telnet installation
Status: CLOSED DUPLICATE of bug 173072
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2005-11-13 12:42 EST by Lee Wilson
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-11-13 12:48:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Lee Wilson 2005-11-13 12:42:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.12) Gecko/20050919 Firefox/1.0.7 (ax)

Description of problem:
When trying to perform a text mode telnet installation on RHEL4U2 the telnet connection is immediately dropped upon the telnet connection attempt

If you use 'linux text telnet dhcp' as the boot line the system boots and displayed the message 'waiting for telnet connection' but as soon as you connect the telnet is dropped and installation proceeds as if telnet was not used.

If you use 'linux text telnet ip=x.x.x.x netmask=x.x.x.x' the system boots and appears to freeze on the 'running /sbin/loader' line until a telnet connection is established at wich point the connection is dropped and install proceeds as above.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot from a RHEL4U2 CD
2. Use 'linux text telnet ip=x.x.x.x netmask=x.x.x.x.x' or 'linux text telnet dhcp' as the boot line
3. Ping the host until it replies (use Alt+F3 to determine IP address if using dhcp).
4. Once it replies or the 'waiting for telnet connection' box appears attempt to connect using telnet. 


Actual Results:  Boot up proceeds as normal and either stops on 'waiting for telnet connection' or 'running /sbin/loader' prompt.

Expected Results:  Installer should allow (i.e. not drop) the telnet connection and display the installer the the remote workstation telnet client.

Additional info:

Telnet seems to work fine using these steps on Fedora Core 4.

Have tried using telnet from Windows (XP & 2000) as well as Gnome Terminal on Fedora Core 4.
Comment 1 Lee Wilson 2005-11-13 12:48:27 EST

*** This bug has been marked as a duplicate of 173072 ***

Note You need to log in before you can comment on or make changes to this bug.