Bug 1730741 - NoMethodError: undefined method `cfme' for #<MiqAeMethodService::MiqAeService:0x0000000018ba6a68>
Summary: NoMethodError: undefined method `cfme' for #<MiqAeMethodService::MiqAeService...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.10.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.10.z
Assignee: Tina Fitzgerald
QA Contact: Sudhir Mallamprabhakara
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-17 13:54 UTC by Niladri Roy
Modified: 2019-07-18 14:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-18 13:05:43 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Niladri Roy 2019-07-17 13:54:24 UTC
Description of problem:
Service provisioning fails with below error

[----] E, [2019-07-16T09:27:33.520882 #21042:8f634f4] ERROR -- : Q-task_id([r1000000000103_service_template_provision_request_1000000000103]) <AEMethod get_request_type> The following error occurred during method evaluation:
[----] E, [2019-07-16T09:27:33.521253 #21042:8f634f4] ERROR -- : Q-task_id([r1000000000103_service_template_provision_request_1000000000103]) <AEMethod get_request_type>   NoMethodError: undefined method `cfme' for #<MiqAeMethodService::MiqAeService:0x0000000011010d68>
[----] E, [2019-07-16T09:27:33.521658 #21042:8f634f4] ERROR -- : Q-task_id([r1000000000103_service_template_provision_request_1000000000103]) <AEMethod get_request_type>   (drbunix:///tmp/automation_engine20190716-21042-8vqa8w) /usr/share/ruby/drb/drb.rb:1624:in `perform_without_block'

Version-Release number of selected component (if applicable):
5.10.6.1

How reproducible:
everytime at Cu env

Steps to Reproduce:
1. service provisioning on vmware provider
2.
3.

Actual results:
requests are not even passing auto-approval

Expected results:
service should be provisioned successfully

Additional info:
this is happening after migration of the database to external postgresql 9.4

Comment 3 Niladri Roy 2019-07-18 11:02:03 UTC
Root cause of this issue was found out to be a faulty database restore at customer's end.
This BZ can be closed


Note You need to log in before you can comment on or make changes to this bug.