Bug 1730757 - novajoin_tempest_plugin tests return IndexError: list index out of range
Summary: novajoin_tempest_plugin tests return IndexError: list index out of range
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-novajoin-tests-tempest
Version: 15.0 (Stein)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: z2
: 15.0 (Stein)
Assignee: Ade Lee
QA Contact: Pavan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-17 14:32 UTC by Pavan
Modified: 2019-12-03 17:21 UTC (History)
7 users (show)

Fixed In Version: python-novajoin-tests-tempest-0.0.1-0.20190923150420.80dd51a.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-03 17:21:30 UTC
Target Upstream Version:
rmascena: needinfo+
rmascena: needinfo+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 679391 'None' MERGED Fix index errors 2020-02-24 14:23:36 UTC
Red Hat Product Errata RHEA-2019:2811 None None None 2019-09-21 11:24:19 UTC

Description Pavan 2019-07-17 14:32:22 UTC
Description of problem:
novajoin_tempest_plugin.tests.scenario returns 'IndexError: list index out of range'

Captured traceback:
~~~~~~~~~~~~~~~~~~~
    b'Traceback (most recent call last):'
    b'  File "/usr/lib/python3.6/site-packages/novajoin_tempest_plugin/tests/scenario/test_novajoin_enrollment.py", line 151, in test_enrollment_metadata_in_image'
    b"    net_id = networks['networks'][0]['id']"
    b'IndexError: list index out of range'
    b''


Version-Release number of selected component (if applicable):
RHOS_TRUNK-15.0-RHEL-8-20190708.n.2

How reproducible:
Occasionally noticed

Steps to Reproduce:
1. Deploy RHOS-15 with 'passed_phase1' or the latest puddle
2. Install 'openstack-tempest-all' and 'python3-novajoin-tests-tempest' packages
3. source /home/stack/overcloudrc
4. On the undercloud /home/stack dir, create workspace for tempest

(undercloud) [stack@undercloud-0 ~]$ tempest init novajoin_tempest
2019-07-15 10:27:23.909 1025847 INFO tempest [-] Using tempest config file /etc/tempest/tempest.conf

5. cd novajoin_tempest
6. Configure the tempest.conf as per novajoin tempest tests 

discover-tempest-config --out etc/tempest.conf --deployer-input ~/tempest-deployer-input.conf --debug --create identity.uri $OS_AUTH_URL auth.admin_password $OS_PASSWORD auth.admin_username $OS_USERNAME auth.use_dynamic_credentials true network.tenant_network_cidr 172.17.2.0/24 validation.connect_method 'fixed' validation.network_for_ssh 'ctlplane' compute.allow_tenant_isolation 'True' object-storage.operator_role 'swiftoperator' novajoin.tripleo_controllers 'controller-0,controller-1,controller-2' novajoin.tripleo_computes 'compute-0,compute-1' novajoin.tripleo_undercloud 'undercloud-0' novajoin.flavor_tag baremetal image.image_path http://download-node-02.eng.bos.redhat.com/qa/rhts/lookaside/security-dfg/python-novajoin/Fedora-Cloud-Base-29-1.2.x86_64.qcow2 image.http_image http://download-node-02.eng.bos.redhat.com/qa/rhts/lookaside/security-dfg/python-novajoin/Fedora-Cloud-Base-29-1.2.x86_64.qcow2 validation.image_ssh_user fedora

7. execute novajoin tempest tests

(overcloud) [stack@undercloud-0 novajoin]$ tempest run --regex novajoin_tempest_plugin

Actual results:
Tests return IndexError: list index out of range error

Expected results:
All tests pass/ok


Additional info:
Tests that fail with this error are listed below:
1.novajoin_tempest_plugin.tests.scenario.test_tripleo_deployment.TripleOTest.test_overcloud_hosts_are_ipaclients
2.novajoin_tempest_plugin.tests.scenario.test_tripleo_deployment.TripleOTest.test_verify_compact_services_created
3.novajoin_tempest_plugin.tests.scenario.test_tripleo_tls.TripleOTLSTest.test_haproxy_tls_connections
4.novajoin_tempest_plugin.tests.scenario.test_tripleo_deployment.TripleOTest.test_verify_compute_certs_are_tracked
5.novajoin_tempest_plugin.tests.scenario.test_tripleo_tls.TripleOTLSTest.test_libvirt_tls_connection
6.novajoin_tempest_plugin.tests.scenario.test_tripleo_deployment.TripleOTest.test_verify_controller_certs_are_tracked
7.novajoin_tempest_plugin.tests.scenario.test_tripleo_tls.TripleOTLSTest.test_mysql_nova_connection_with_ssl
8.novajoin_tempest_plugin.tests.scenario.test_tripleo_deployment.TripleOTest.test_verify_controller_managed_services
9.novajoin_tempest_plugin.tests.scenario.test_novajoin_enrollment.ServerTest.test_enrollment_metadata_in_image
10.novajoin_tempest_plugin.tests.scenario.test_novajoin_enrollment.ServerTest.test_enrollment_metadata_in_image
11.novajoin_tempest_plugin.tests.scenario.test_tripleo_tls.TripleOTLSTest.test_rabbitmq_tls_connection
12.novajoin_tempest_plugin.tests.scenario.test_novajoin_enrollment.ServerTest.test_enrollment_metadata_in_instance


======
Totals
======
Ran: 14 tests in 10.7829 sec.
 - Passed: 1
 - Skipped: 0
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 13
Sum of execute time for each test: 5.4768 sec.

------------------------------------------------------------------------------------
access the undercloud sos report here: https://drive.google.com/open?id=149fU1k9p52q9khOAWvprgiLxHbE8_T7P

Comment 11 errata-xmlrpc 2019-09-21 11:24:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.