Bug 1730762 - Mouse (optical A4tech) doesn't scroll in the kernels 5.1.17 and 5.1.18.
Summary: Mouse (optical A4tech) doesn't scroll in the kernels 5.1.17 and 5.1.18.
Keywords:
Status: ON_QA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 30
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-17 14:42 UTC by LukasH
Modified: 2019-08-09 13:59 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Linux Kernel 203369 None None None 2019-08-07 21:46:29 UTC

Description LukasH 2019-07-17 14:42:29 UTC
1. Please describe the problem:

Problem with (at least) this optical mouse from A4 :

$ lsusb
...
Bus 003 Device 002: ID 09da:000a A4Tech Co., Ltd. Optical Mouse Opto 510D / OP-620D

Scrolling wheel worked well till 5.1.16 kernel, but stopped the work under the 5.1.17 kernel. In 5.1.18 problem still remains.


2. What is the Version-Release number of the kernel:

5.1.17-300.fc30.x86_64, 5.1.18-300.fc30.x86_64


3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

It did work until 5.1.16. Fist appears in 5.1.17.


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

Just start the machine with 5.1.17 or 5.1.18 kernel. After the reboot into 5.1.16 kernel problem is solved.


6. Are you running any modules that not shipped with directly Fedora's kernel?:

Only Oracle VBox extension pack - which is very probably isn't related in any way.

Comment 1 Jeremy Cline 2019-07-17 15:54:39 UTC
Hi Lukas,

It looks like the issue has been discovered and there's a proposed patch. I started a kernel build with the patch if you'd like to test it: https://koji.fedoraproject.org/koji/taskinfo?taskID=36303951.

Comment 2 LukasH 2019-07-17 16:05:50 UTC
Thanks Jeremy, if I grab somewhere a bit of free time, I'll try it. Just a question - is this koji build only src (and have I rebuild from src into binary), or is somewhere over there also direct x86_64 variant ? Thanks again...

Comment 3 Jeremy Cline 2019-07-17 16:07:48 UTC
It's a binary build for x86_64, the RPMs will be attached to https://koji.fedoraproject.org/koji/taskinfo?taskID=36303953 when the build completes. You'll need the kernel, kernel-core, and kernel-modules rpms at a minimum.

Comment 4 LukasH 2019-07-18 15:17:45 UTC
Great! I installed this "5.1.18 kernel family" (rhbz1730762) before a while and can confirm that everything (including the mouse vertical scrolling) is working like a charm ... thanks again, Jeremy! Anyway, will be this patch an official part of 5.1.19 kernel ?

Comment 5 Jeremy Cline 2019-07-18 15:49:37 UTC
Thanks for testing!

I sent an email to upstream about the patch since it seems stalled. Once they decide what to do I'll pick it up or whatever alternate is proposed for Fedora kernels until it filters back into upstream stable kernels (which will likely take a bit of time).

Comment 6 LukasH 2019-07-23 12:58:19 UTC
I've been installed 5.1.19-300.fc30.x86_64 from testing repository before a while, and it looks like the mouse scroll is broken again. Probably you missed to push that patch into newer kernel ... ? ;)

Comment 7 Jeremy Cline 2019-07-23 14:38:30 UTC
Bleh, you're right, I lost track of this. Upstream hasn't responded yet, I'll added the input folks to the bug Cc. I'd rather not pick up the fix until upstream decides on something because it's too easy to lose track of things and then it never gets fixed properly (or upstream fixes it some other way and we have a weird patch until someone notices). Sorry about that.

Comment 8 erin.dru 2019-07-23 17:28:57 UTC
Apologies if this is considered spam - I didn't see a "Me Too" button.

Anyway - this issue is occurring for me too. I was quite surprised, I thought my mouse was cheap and generic enough to "always work" but upon closer inspection it is indeed an A4Tech mouse that is affected by this issue.

Comment 9 LukasH 2019-07-26 14:50:12 UTC
I understand this situation, Jeremy, I'm just afraid that we'd wait for the upstream reaction (with pushing the final patch into stable kernel) for a long months (hopefully not, but...). So, could you be so kind, please, and push this patch at least to the first kernel from 5.2, that will go into testing and then stable repository (I guess 5.2.3 or 5.2.4) ? I don't want to hang on 5.1 series for that long months. But maybe upstream already made some action and my fear is not necessary, who knows ;)

Comment 10 Jeremy Cline 2019-07-26 15:11:09 UTC
The upstream discussion is at https://lore.kernel.org/lkml/20190611121320.30267-1-nsaenzjulienne@suse.de/ and there are instructions at the bottom of the page on how to respond if you'd like to add your voice to the conversation. As soon as upstream says something I'm happy to pick it up, but we want to make sure fixes are actually going to go upstream or we'll be stuck carrying a patch forever and it'll still be broken for everyone who's not using the Fedora kernel.

Comment 11 LukasH 2019-07-29 21:44:45 UTC
I urged this at bugzilla.kernel.org (#204179), but probably nobody is paying attention about this till now (and it looks like the same with discussion at lore.kernel.org, as you mentioned). Sad ... it will be probably really 'run for a long distance', I'm afraid. So, please, Jeremy, if it will be possible, could you implant this patch _just_ for (freshly new in pending status) 5.2.4-200.fc30 kernel (or - if it's too late already for rebuilding - for the next 5.2.5-200.fc30) ? Then I (or all our impacted group with A4tech mice ;) ) will able to rebase my desktop for 5.2 kernel series and patiently wait for the further upstream decision ... thanks!

Comment 12 LukasH 2019-07-31 09:04:36 UTC
Re-opened/new ticket at bugzilla.kernel.org here :

https://bugzilla.kernel.org/show_bug.cgi?id=204347

Still without any reaction from upstream till now. So, would it be possible to implant this patch _just_ into 5.2.5 (fc30) kernel, please ? Thanks!

Comment 13 LukasH 2019-08-01 14:16:04 UTC
I observed kernel 5.2.5-200.fc30 in the testing repository before a while. Is this (a4tech) patch included, please? I'm asking before testing, as I don't want to rebase my F30 for 5.2 series (kernel-headers, tools, etc.), if it'd be useless then.

Comment 14 Jeremy Cline 2019-08-01 19:32:51 UTC
Hi, it is not included. Here is a scratch build with the patch applied: https://koji.fedoraproject.org/koji/taskinfo?taskID=36740602. Please, though, engage with upstream. Fedora has a reasonably strict upstream-first policy and this is not the right place to fix the problem.

Comment 15 LukasH 2019-08-01 20:12:09 UTC
Yeah, Jeremy, I understand that policies (I just thought that you'd rebuild "special/alternative" rhbz kernel with this patch for 5.2.5, in the same way as you already did for 5.1.18). Of course escalation of this issue by upstream bugzilla is the right way (and several people, such as me, constantly do it), I hope that something will happen soon, even if there is still no response till now. Thanks for this scratch build in any case!

Comment 16 Fedora Update System 2019-08-06 12:43:54 UTC
FEDORA-2019-a7f551b8c9 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a7f551b8c9

Comment 17 Fedora Update System 2019-08-07 01:07:44 UTC
kernel-5.2.6-200.fc30, kernel-headers-5.2.6-200.fc30, kernel-tools-5.2.6-200.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a7f551b8c9

Comment 18 Fedora Update System 2019-08-09 01:03:17 UTC
kernel-5.2.6-200.fc30, kernel-headers-5.2.6-200.fc30, kernel-tools-5.2.6-200.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 LukasH 2019-08-09 13:59:57 UTC
I can confirm that in 5.2.6-200.fc30.x86_64 mouse (A4tech) scrolling works well as expected. Thanks to all who solved this issue!


Note You need to log in before you can comment on or make changes to this bug.