Bug 1730824 (CVE-2019-10352) - CVE-2019-10352 jenkins: Arbitrary file write vulnerability using file parameter definitions (SECURITY-1424)
Summary: CVE-2019-10352 jenkins: Arbitrary file write vulnerability using file paramet...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2019-10352
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1730827 1731021 1731024 1731034
Blocks: 1730879
TreeView+ depends on / blocked
 
Reported: 2019-07-17 19:06 UTC by Laura Pardo
Modified: 2019-11-29 05:39 UTC (History)
16 users (show)

Fixed In Version: jenkins weekly 2.186, Jenkins LTS 2.176.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-15 14:47:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:2503 None None None 2019-08-15 13:28:54 UTC
Red Hat Product Errata RHSA-2019:2548 None None None 2019-08-28 17:02:07 UTC

Description Laura Pardo 2019-07-17 19:06:35 UTC
A vulnerability was found in Jenkins versions weekly before 2.186 and LTS before 2.176.2. Users with Job/Configure permission could specify a relative path escaping the base directory in the file name portion of a file parameter definition. This path would be used to store the uploaded file on the Jenkins master, resulting in an arbitrary file write vulnerability. This vulnerability is the result of an incomplete fix for SECURITY-1074. File parameters that escape the base directory are no longer accepted and the build will fail.

Comment 1 Laura Pardo 2019-07-17 19:06:39 UTC
External References:

https://jenkins.io/security/advisory/2019-07-17/

Comment 2 Laura Pardo 2019-07-17 19:07:01 UTC
Created jenkins tracking bugs for this issue:

Affects: fedora-all [bug 1730827]

Comment 5 Sam Fowler 2019-07-18 07:25:13 UTC
"Any security advisory related updates to Jenkins core or the plugins we include in the OpenShift Jenkins master image will only occur in the v3.11 and v4.x branches of this repository."

https://github.com/openshift/jenkins/blob/master/README.md#jenkins-security-advisories-the-master-image-from-this-repository-and-the-oc-binary

Comment 6 errata-xmlrpc 2019-08-15 13:28:53 UTC
This issue has been addressed in the following products:

  Red Hat OpenShift Container Platform 3.11

Via RHSA-2019:2503 https://access.redhat.com/errata/RHSA-2019:2503

Comment 7 Product Security DevOps Team 2019-08-15 14:47:03 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2019-10352

Comment 8 errata-xmlrpc 2019-08-28 17:02:06 UTC
This issue has been addressed in the following products:

  Red Hat OpenShift Container Platform 4.1

Via RHSA-2019:2548 https://access.redhat.com/errata/RHSA-2019:2548


Note You need to log in before you can comment on or make changes to this bug.