Bug 1730843 - Mono 5.18.1.28 does not build for ppc64le
Summary: Mono 5.18.1.28 does not build for ppc64le
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: mono
Version: rawhide
Hardware: ppc64le
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2019-07-17 19:10 UTC by Timotheus Pokorra
Modified: 2019-07-22 10:27 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-22 05:07:05 UTC


Attachments (Terms of Use)

Description Timotheus Pokorra 2019-07-17 19:10:44 UTC
see build https://koji.fedoraproject.org/koji/taskinfo?taskID=36304162

These are the relevant lines in the build log:

BUILDSTDERR:   CC       libmonoutils_la-mono-contmono-error.c:573:1: warning: 'mono_error_prepare_exception_handle' defined but not used [-Wunused-function]
BUILDSTDERR:   573 | mono_error_prepare_exception_handle (MonoError *oerror, MonoError *error_out)
BUILDSTDERR:       | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
BUILDSTDERR: In file included from mono-context.c:10:
BUILDSTDERR: mono-context.c: In function 'mono_sigctx_to_monoctx':
BUILDSTDERR: ../../mono/utils/mono-sigcontext.h:334:81: error: 'PT_NIP' undeclared (first use in this function)
BUILDSTDERR:   334 |  #define UCONTEXT_REG_NIP(ctx)     (((os_ucontext*)(ctx))->uc_mcontext.gp_regs [PT_NIP])
BUILDSTDERR:       |                                                                                 ^~~~~~
BUILDSTDERR: mono-context.c:533:16: note: in expansion of macro 'UCONTEXT_REG_NIP'
BUILDSTDERR:   533 |  mctx->sc_ir = UCONTEXT_REG_NIP(uc);
BUILDSTDERR:       |                ^~~~~~~~~~~~~~~~
BUILDSTDERR: ../../mono/utils/mono-sigcontext.h:334:81: note: each undeclared identifier is reported only once for each function it appears in
BUILDSTDERR:   334 |  #define UCONTEXT_REG_NIP(ctx)     (((os_ucontext*)(ctx))->uc_mcontext.gp_regs [PT_NIP])
BUILDSTDERR:       |                                                                                 ^~~~~~
BUILDSTDERR: mono-context.c:533:16: note: in expansion of macro 'UCONTEXT_REG_NIP'
BUILDSTDERR:   533 |  mctx->sc_ir = UCONTEXT_REG_NIP(uc);
BUILDSTDERR:       |                ^~~~~~~~~~~~~~~~
BUILDSTDERR: mono-context.c: In function 'mono_monoctx_to_sigctx':
BUILDSTDERR: ../../mono/utils/mono-sigcontext.h:334:81: error: 'PT_NIP' undeclared (first use in this function)
BUILDSTDERR:   334 |  #define UCONTEXT_REG_NIP(ctx)     (((os_ucontext*)(ctx))->uc_mcontext.gp_regs [PT_NIP])
BUILDSTDERR:       |                                                                                 ^~~~~~
BUILDSTDERR: mono-context.c:549:2: note: in expansion of macro 'UCONTEXT_REG_NIP'
BUILDSTDERR:   549 |  UCONTEXT_REG_NIP(uc) = mctx->sc_ir;
BUILDSTDERR:       |  ^~~~~~~~~~~~~~~~
BUILDSTDERR: make[5]: *** [Makefile:1370: libmonoutils_la-mono-context.lo] Error 1

Comment 1 Timotheus Pokorra 2019-07-17 19:11:58 UTC
this issue might be similar: https://github.com/gperftools/gperftools/issues/1009
but I did not understand what the solution would be.

Comment 2 Dan Horák 2019-07-17 20:43:23 UTC
This is definitely not a problem with mono trunk, sounds like a change in the 5.18 branch, will take a look ...

Comment 3 Timotheus Pokorra 2019-07-20 21:08:23 UTC
Seems it builds in Rawhide without changes, according to Koschei.
I will close the bug on Monday, if the build succeeds.

Comment 4 Timotheus Pokorra 2019-07-22 05:07:05 UTC
It seems something outside of Mono was broken in Rawhide, it is working again.

Comment 5 Dan Horák 2019-07-22 10:27:27 UTC
It could have been caused by the kernel-headers package in Rawhide, it was broken for a short while after introducing 5.3-pre kernels.


Note You need to log in before you can comment on or make changes to this bug.