Bug 1730947 - [RFE] Unpause VMs after NFS storage for Cinder hit 100% - CLI commands
Summary: [RFE] Unpause VMs after NFS storage for Cinder hit 100% - CLI commands
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: nova-maint
QA Contact: nova-maint
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-18 02:08 UTC by Cristian Muresanu
Modified: 2020-12-21 19:40 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-29 10:10:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Cristian Muresanu 2019-07-18 02:08:19 UTC
Description of problem:
Official solution for remediation of issues where /var/lib/cinder/mnt goes to 100%.

Unpause VMs in Paused State after NFS storage for Cinder hit 100%
After expand the NFS Filesystem space we ran the below command on every compute node to resume the VMs from the libvirt layer
#virsh list | grep -i pause | awk '{print $2}'|xargs -i virsh resume {} 

Looking for an official document to fix this using openstack commands as 
- nova reset-state [--all-tenants] [--active] <server> [<server>]
- nova resume <server>
etc...

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Matthew Booth 2019-07-26 13:43:34 UTC
I'm assuming here that this happened because the Cinder volumes aren't preallocated?

Need to discuss with the team how we think Nova should act here.

Comment 2 Matthew Booth 2019-07-26 14:49:38 UTC
The agreement was that Nova should notice that the VM is paused and move it to the paused state.


Note You need to log in before you can comment on or make changes to this bug.