Bug 1731031 - cvc4: symbol lookup error: /lib64/libcvc4.so.6: undefined symbol: _ZN7CaDiCaL6Solver3setEPKci
Summary: cvc4: symbol lookup error: /lib64/libcvc4.so.6: undefined symbol: _ZN7CaDiCaL...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cvc4
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Jerry James
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-18 07:25 UTC by Thomas Pointhuber
Modified: 2019-08-02 01:00 UTC (History)
3 users (show)

Fixed In Version: cvc4-1.7-3.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-02 01:00:53 UTC


Attachments (Terms of Use)

Description Thomas Pointhuber 2019-07-18 07:25:33 UTC
Description of problem:

cvc4 cannot be executed due to a compiler/linker error

$ cvc4
cvc4: symbol lookup error: /lib64/libcvc4.so.6: undefined symbol: _ZN7CaDiCaL6Solver3setEPKci


Version-Release number of selected component (if applicable):

$ dnf info cvc4
Last metadata expiration check: 0:15:31 ago on Thu Jul 18 09:07:13 2019.
Installed Packages
Name         : cvc4
Version      : 1.7
Release      : 1.fc30
Architecture : x86_64
Size         : 868 k
Source       : cvc4-1.7-1.fc30.src.rpm
Repository   : @System
From repo    : updates
Summary      : Automatic theorem prover for SMT problems
URL          : http://cvc4.cs.stanford.edu/
License      : Boost and BSD and MIT
Description  : CVC4 is an efficient open-source automatic theorem prover for
             : satisfiability modulo theories (SMT) problems.  It can be used to prove
             : the validity (or, dually, the satisfiability) of first-order formulas in
             : a large number of built-in logical theories and their combination.
             : 
             : CVC4 is the fourth in the Cooperating Validity Checker family of tools
             : (CVC, CVC Lite, CVC3) but does not directly incorporate code from any
             : previous version.  A joint project of NYU and U Iowa, CVC4 aims to
             : support the  features of CVC3 and SMT-LIBv2 while optimizing the design
             : of the core system architecture and decision procedures to take
             : advantage of recent engineering and algorithmic advances.
             : 
             : CVC4 is intended to be an open and extensible SMT engine, and it can be
             : used as a stand-alone tool or as a library, with essentially no limit on
             : its use for research or commercial purposes.

How reproducible:


Steps to Reproduce:
1. install cvc4
2. try to execute cvc4

Actual results:

cvc4: symbol lookup error: /lib64/libcvc4.so.6: undefined symbol: _ZN7CaDiCaL6Solver3setEPKci

Expected results:

working binary

Additional info:

-

Comment 1 Fedora Update System 2019-07-20 02:57:59 UTC
FEDORA-2019-d03acc263f has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d03acc263f

Comment 2 Fedora Update System 2019-07-21 01:00:07 UTC
cvc4-1.7-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d03acc263f

Comment 3 Fedora Update System 2019-07-24 17:29:30 UTC
FEDORA-2019-d03acc263f has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d03acc263f

Comment 4 Fedora Update System 2019-07-25 01:19:50 UTC
cadical-1.0.3-3.fc30, cvc4-1.7-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d03acc263f

Comment 5 Fedora Update System 2019-08-02 01:00:53 UTC
cadical-1.0.3-3.fc30, cvc4-1.7-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.