Bug 173107 - Openoffice crashes, writer, impress, anything
Openoffice crashes, writer, impress, anything
Status: CLOSED DUPLICATE of bug 172930
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-14 03:10 EST by Dan Fruehauf
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-14 04:01:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Fruehauf 2005-11-14 03:10:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051103 Fedora/1.5-0.5.0.rc1 Firefox/1.5

Description of problem:
This is happened to me by far already too much.
I dont have any special preferences for openoffice yet i still experience these crashes.

Here is the stack trace, perhaps it could mean something :
0x45b08a5: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e8a5
0x45b10a8: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1f0a8
0x3ec420:  + 0x420 (__kernel_sigreturn + 0x0)
0x4fa1820: /usr/lib/libicuuc.so.34 + 0x9f820 (icu_3_4::RuleBasedBreakIterator::R
uleBasedBreakIterator(UDataMemory*, UErrorCode&) + 0x56)
0x785c99d: /usr/lib/openoffice.org2.0/program/i18npool.uno.so + 0x4299d
0x785d10b: /usr/lib/openoffice.org2.0/program/i18npool.uno.so + 0x4310b
0x7859fc1: /usr/lib/openoffice.org2.0/program/i18npool.uno.so + 0x3ffc1
0xb2013226: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x31f226
0xb201b853: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x327853
0xb1fe08cd: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2ec8cd
0xb1fe0209: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2ec209
0xb1fcd79e: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2d979e
0xb1fce3c5: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2da3c5
0xb1fb9d17: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2c5d17
0xb1fb9d17: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2c5d17
0xb1fbc5d7: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2c85d7
0xb1fbc76f: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2c876f
0xb1eaa9ba: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1b69ba (SwCrsrS
hell::GetContentAtPos(Point const&, SwContentAtPos&, int, SwRect*) + 0xca)
0xb1edcfb1: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1e8fb1 (SwFEShe
ll::IsNumLabel(Point const&, int) + 0x35)
0xb22f8ffc: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x604ffc
0x4cf8844: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1db844
0x4cf9f29: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1dcf29
0x4cf8cd1: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1dbcd1
0x139eae: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x28eae
0x136fab: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x25fab
0x57f40cc: /usr/lib/libgtk-x11-2.0.so.0 + 0x1160cc
0x5628bd8: /usr/lib/libgobject-2.0.so.0 + 0x8bd8 (g_closure_invoke + 0x11e)
0x5637213: /usr/lib/libgobject-2.0.so.0 + 0x17213
0x56385c3: /usr/lib/libgobject-2.0.so.0 + 0x185c3 (g_signal_emit_valist + 0x41e)
0x5638bc3: /usr/lib/libgobject-2.0.so.0 + 0x18bc3 (g_signal_emit + 0x29)
0x58d64ff: /usr/lib/libgtk-x11-2.0.so.0 + 0x1f84ff
0x57f2807: /usr/lib/libgtk-x11-2.0.so.0 + 0x114807 (gtk_propagate_event + 0xc1)
0x57f2c40: /usr/lib/libgtk-x11-2.0.so.0 + 0x114c40 (gtk_main_do_event + 0x325)
0x53996f3: /usr/lib/libgdk-x11-2.0.so.0 + 0x3e6f3
0x995a50: /usr/lib/libglib-2.0.so.0 + 0x24a50 (g_main_context_dispatch + 0x1dc)
0x998a66: /usr/lib/libglib-2.0.so.0 + 0x27a66
0x998f48: /usr/lib/libglib-2.0.so.0 + 0x27f48 (g_main_context_iteration + 0x66)
0x129f23: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x18f23
0x3b1852: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x46852 (X                                           11SalInstance::Yield(unsigned char) + 0x28)
0x4ba634c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8934c (Applicat                                           ion::Yield() + 0x48)
0x4ba6382: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x89382 (Applicat                                           ion::Execute() + 0x26)
0x5fd37ba: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x257ba (desktop::                                           Desktop::Main() + 0x15b0)
0x4bab747: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e747
0x4bab7f7: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e7f7 (SVMain()                                            + 0x29)
0x5fcb05f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1d05f (sal_main                                            + 0x57)
0x5fcb0ab: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1d0ab (main + 0x                                           27)
0xa5050f: /lib/libc.so.6 + 0x1550f (__libc_start_main + 0xdf)
0x80484a5: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x4a5


Version-Release number of selected component (if applicable):
2.0.1-0.138.3.2

How reproducible:
Sometimes

Steps to Reproduce:
1. Open writer with a new document
2. Work just about a little
3. Crash
  

Actual Results:  Openoffice writer crashed.
Impress would also do the same thing. I am not hoping this would be solved easily, but the stack trace should be pretty helpful. If needed I could provide a core and perhaps do some tricks with gdb if requested.

Expected Results:  Openoffice writer should be stable!

Additional info:

Note that I'm working with rawhide.

If needed I have no problems of removing personal preferences of openoffice - but as I previously said - that didn't help me much.
Comment 1 Caolan McNamara 2005-11-14 04:01:11 EST
should be ok in next respin

*** This bug has been marked as a duplicate of 172930 ***

Note You need to log in before you can comment on or make changes to this bug.