Bug 1731073 - Firefox 68.0.1 available by today
Summary: Firefox 68.0.1 available by today
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 31
Hardware: All
OS: All
unspecified
urgent
Target Milestone: ---
Assignee: Jan Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1731246 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-18 09:41 UTC by JayJayJazz
Modified: 2019-08-24 18:09 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-24 18:09:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 1553228 None None None 2019-08-08 11:46:32 UTC
Mozilla Foundation 1558503 None None None 2019-08-08 11:46:32 UTC
Mozilla Foundation 1562837 None None None 2019-08-08 11:46:32 UTC
Mozilla Foundation 1565315 None None None 2019-08-08 11:46:32 UTC
Mozilla Foundation 1565779 None None None 2019-08-08 11:46:32 UTC
Mozilla Foundation 1566062 None None None 2019-08-08 11:46:33 UTC

Description JayJayJazz 2019-07-18 09:41:06 UTC
Description of problem:
Firefox 68.0.1 available by today

Version-Release number of selected component (if applicable):
68.0.1

Additional info:
The 68.0.1 builds are already available on the Mozilla FTP:
https://ftp.mozilla.org/pub/firefox/releases/68.0.1/

The release notes are not yet available, but should be later this day:
https://www.mozilla.org/en-US/firefox/68.0.1/releasenotes/


A special Linux regression will be fixed in 68.0.1:
https://bugzilla.mozilla.org/show_bug.cgi?id=1553228
https://bugzilla.mozilla.org/show_bug.cgi?id=1566062

Comment 1 JayJayJazz 2019-07-18 16:14:52 UTC
The release notes are available now:
https://www.mozilla.org/en-US/firefox/68.0.1/releasenotes/

- macOS releases are now signed by the Apple notary service, allowing Firefox to properly run on macOS 10.15 Beta releases
- Fixed missing Full Screen button when watching videos in full screen mode on HBO GO
- Fixed a bug causing incorrect messages to appear for some locales when sites try to request the use of the Storage Access API
- Users in Russian regions may have their default search engine changed
- Built-in search engines in some locales do not function correctly

Comment 2 JayJayJazz 2019-08-09 09:25:37 UTC
Hi @stransky, Hi @xhorak,

any plan, when the 68.0.1 will be available? Only a F31 (firefox-68.0.1-3.fc31) seems to be available in "testing".
Have the build problems been fixed? As far as I have seen, there will be a 68.0.2 next week. (at least the last channel meeting mentions this: https://wiki.mozilla.org/Firefox/Channels/Meetings/2019-08-08)

Comment 3 Martin Stransky 2019-08-09 09:31:55 UTC
Moving to Jan as I'm going to PTO next week and he's investigated the build issues already. FF 68.0.2 may come next week, we may ship that. Koji builders are broken due to rust version used there so we may switch to -j1 temporary to do that builds.

Comment 4 Christian Stadelmann 2019-08-12 20:11:23 UTC
*** Bug 1731246 has been marked as a duplicate of this bug. ***

Comment 5 Ben Cotton 2019-08-13 17:04:11 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 6 Ben Cotton 2019-08-13 17:09:22 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 7 Marko Bevc 2019-08-24 09:45:05 UTC
This can be closed now - 68.0.2 was already released.


Note You need to log in before you can comment on or make changes to this bug.