Bug 173108 - Openoffice crashes when changing graph properities
Openoffice crashes when changing graph properities
Status: CLOSED DUPLICATE of bug 172930
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-14 03:38 EST by Radek Vokal
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-14 04:02:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Vokal 2005-11-14 03:38:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20051008 Fedora/1.5-0.5.0.beta2 Firefox/1.4.1

Description of problem:
When changing graph properitis (by clicking on graph points and selecting Object properities, adding power regression and again selecting Object properties) openoffice.org-calc hangs with following backtrace

Version-Release number of selected component (if applicable):
openoffice.org-calc-2.0.1-0.138.3.2

How reproducible:
Always

Steps to Reproduce:
1. create graph
2. select Object properities for graph points
3. add regression
4. select Object properities

Actual Results:  0x49a88a5: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e8a5
0x49a90a8: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1f0a8
0x1b1420:  + 0x420 (__kernel_sigreturn + 0x0)
0x3641820: /usr/lib/libicuuc.so.34 + 0x9f820 (icu_3_4::RuleBasedBreakIterator::RuleBasedBreakIterator(UDataMemory*, UErrorCode&) + 0x56)
0x54c999d: /usr/lib/openoffice.org2.0/program/i18npool.uno.so + 0x4299d
0x54ca087: /usr/lib/openoffice.org2.0/program/i18npool.uno.so + 0x43087
0x54c6f2b: /usr/lib/openoffice.org2.0/program/i18npool.uno.so + 0x3ff2b
0x682f3ed: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x27c3ed
0x6833755: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x280755
0x683387e: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x28087e
0x682b122: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x278122
0x681f3d9: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x26c3d9 (EditView::GetField(Point const&, unsigned short*, unsigned short*) const + 0x23)
0x6b09715: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x556715 (SdrView::PickAnything(Point const&, SdrViewEvent&) const + 0x79b)
0x6b0a196: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x557196 (SdrView::GetPreferedPointer(Point const&, OutputDevice const*, unsigned short, unsigned char) const + 0x278)
0x5e450d6: /usr/lib/openoffice.org2.0/program/libsch680li.so + 0xcb0d6
0x5e44b69: /usr/lib/openoffice.org2.0/program/libsch680li.so + 0xcab69
0x5e4620c: /usr/lib/openoffice.org2.0/program/libsch680li.so + 0xcc20c
0x5e5bfdb: /usr/lib/openoffice.org2.0/program/libsch680li.so + 0xe1fdb
0x5e61f2b: /usr/lib/openoffice.org2.0/program/libsch680li.so + 0xe7f2b
0x4b0664: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d3664
0x4b1d49: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d4d49
0x4b0af1: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d3af1
0x5a2aeae: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x28eae
0x5a27fab: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x25fab
0x21940cc: /usr/lib/libgtk-x11-2.0.so.0 + 0x1160cc
0x2547bd8: /usr/lib/libgobject-2.0.so.0 + 0x8bd8 (g_closure_invoke + 0x11e)
0x2556213: /usr/lib/libgobject-2.0.so.0 + 0x17213
0x25575c3: /usr/lib/libgobject-2.0.so.0 + 0x185c3 (g_signal_emit_valist + 0x41e)
0x2557bc3: /usr/lib/libgobject-2.0.so.0 + 0x18bc3 (g_signal_emit + 0x29)
0x22764ff: /usr/lib/libgtk-x11-2.0.so.0 + 0x1f84ff
0x2192807: /usr/lib/libgtk-x11-2.0.so.0 + 0x114807 (gtk_propagate_event + 0xc1)
0x2192c40: /usr/lib/libgtk-x11-2.0.so.0 + 0x114c40 (gtk_main_do_event + 0x325)
0x178b6f3: /usr/lib/libgdk-x11-2.0.so.0 + 0x3e6f3
0x6490a50: /usr/lib/libglib-2.0.so.0 + 0x24a50 (g_main_context_dispatch + 0x1dc)
0x6493a66: /usr/lib/libglib-2.0.so.0 + 0x27a66
0x6493f48: /usr/lib/libglib-2.0.so.0 + 0x27f48 (g_main_context_iteration + 0x66)
0x5a1af23: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x18f23
0x1836852: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x46852 (X11SalInstance::Yield(unsigned char) + 0x28)
0x35e16c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8116c (Application::Yield() + 0x48)
0x35e1a2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x811a2 (Application::Execute() + 0x26)
0x68e8ba: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x248ba (desktop::Desktop::Main() + 0x15b0)
0x363567: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x86567
0x363617: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x86617 (SVMain() + 0x29)
0x68615f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1c15f (sal_main + 0x57)
0x6861ab: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1c1ab (main + 0x27)
0x1c750f: /lib/libc.so.6 + 0x1550f (__libc_start_main + 0xdf)
0x80484c5: /usr/lib/openoffice.org2.0/program/scalc.bin + 0x4c5

Expected Results:  no crash

Additional info:
Comment 1 Caolan McNamara 2005-11-14 04:02:02 EST
should be ok in next respin

*** This bug has been marked as a duplicate of 172930 ***

Note You need to log in before you can comment on or make changes to this bug.